Bug 151296 - [miscompilation] jdt.jar: Preferences are not being saved
[miscompilation] jdt.jar: Preferences are not being saved
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 14:20 EST by Jeff Pound
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-05 11:28:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
stack trace that may relate to this problem (8.65 KB, text/plain)
2005-03-29 15:39 EST, Ben Konrath
no flags Details

  None (edit)
Description Jeff Pound 2005-03-16 14:20:45 EST
Description of problem:
Preferences are not being saved.

Version-Release number of selected component (if applicable):
3.1.0_fc-0.M5.12


Steps to Reproduce:
1. Change a preferences (ex. keys to "emacs" mode).
  
Actual results:
The change does not apply.

Expected results:
The change should apply.
Comment 1 Ben Konrath 2005-03-29 15:39:12 EST
Created attachment 112429 [details]
stack trace that may relate to this problem

To get this stack trace do: 

rm -r .eclipse workspace-test; eclipse -data workspace-test -consolelog -debug
Comment 2 Jeff Pound 2005-03-29 17:10:28 EST
fixed as of eclipse-3.1.0_fc-0.M5.15, above stack trace seems to be unrelated as
it still occurs.
Comment 3 Andrew Overholt 2005-04-20 10:55:36 EDT
This bug appears to have resurfaced with 3.1.0_fc-0.M6.7 and gcc*-4.0.0-0.42. 
Removing /usr/lib/eclipse/plugins/org.eclipse.jdt.ui_3.1.0/jdt.jar.so seems to
solve the problem so it appears to be another miscompilation.
Comment 4 Anthony Green 2005-04-21 10:49:54 EDT
The top of the stack trace reads:

IndexedStoreException:Index not found.
   at org.eclipse.core.internal.indexing.IndexedStore.getIndex(java.lang.String)
(/usr/lib/eclipse/plugins/org.eclipse.core.resources.compatibility_3.1.0/compat
ibility.jar.so)
   at org.eclipse.core.internal.properties.IndexedStoreWrapper.getIndex()
(/usr/lib/eclipse/plugins/org.eclipse.core.resources.compatibility_3.1.0/compatibility
.jar.so)
   at org.eclipse.core.internal.properties.IndexedStoreWrapper.getCursor()
(/usr/lib/eclipse/plugins/org.eclipse.core.resources.compatibility_3.1.0/compatibilit
y.jar.so)
   at
org.eclipse.core.internal.properties.PropertyStore.recordsDeepMatching(org.eclipse.core.internal.properties.ResourceName,
org.eclipse.core.internal.proper ties.IVisitor)
(/usr/lib/eclipse/plugins/org.eclipse.core.resources.compatibility_3.1.0/compatibility.jar.so)
   at
org.eclipse.core.internal.properties.PropertyStoreConverter$1.visit(org.eclipse.core.resources.IResource)
(/usr/lib/eclipse/plugins/org.eclipse.core.resou
rces.compatibility_3.1.0/compatibility.jar.so)
   at
org.eclipse.core.internal.resources.Resource.accept(org.eclipse.core.resources.IResourceVisitor,
int, int) (/usr/lib/eclipse/plugins/org.eclipse.core.reso
urces_3.1.0/resources.jar.so)
   at
org.eclipse.core.internal.properties.PropertyStoreConverter.convertProperties(org.eclipse.core.internal.resources.Workspace,
org.eclipse.core.internal.pro perties.PropertyManager2)
(/usr/lib/eclipse/plugins/org.eclipse.core.resources.compatibility_3.1.0/compatibility.jar.so)
   at
org.eclipse.core.internal.resources.ResourcesCompatibility.createPropertyManager(boolean,
boolean) (/usr/lib/eclipse/plugins/org.eclipse.core.resources.co
mpatibility_3.1.0/compatibility.jar.so)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[])
(/usr/lib/libgcj.so.6.0.0)
   at
org.eclipse.core.internal.resources.ResourcesCompatibilityHelper.createPropertyManager(boolean,
boolean) (/usr/lib/eclipse/plugins/org.eclipse.core.resour
ces_3.1.0/resources.jar.so)


We recently discovered a bug related to libffi and boolean args.  If the 
Method.invoke above always passed true for one or both args, would that
explain the behaviour you're seeing?


Comment 5 Anthony Green 2005-04-21 13:53:27 EDT
Ignore me.  These problems are almost certainly unrelated.  The libffi related
problem only appears for code built with gcj from source - not bytecode.
Comment 6 Jeff Pound 2005-04-28 12:22:44 EDT
Preferences working as of: 3.1.0_fc-0.M6.12 and 4.0.0-1
Comment 7 Jeff Pound 2005-04-28 15:52:40 EDT
Looks like it's only working because the offending .so was removed. The problem
still exists when its there. reopening.
Comment 8 Ben Konrath 2005-05-04 22:00:53 EDT
This seems to have fixed itself, jdt.jar.so is re-enabled as of 3.1.0_fc-0.M6.15
with gcj 4.0.0-2. Andrew, can you verify?
Comment 9 Andrew Overholt 2005-05-05 11:28:08 EDT
I've verified that while running your RPMs,
/usr/lib/eclipse/plugins/org.eclipse.jdt.ui_3.1.0/jdt.jar.so was loaded and my
preference choices "stuck".  Rock on.

Closing NEXTRELEASE (3.1.0_fc-0.M6.15).

Note You need to log in before you can comment on or make changes to this bug.