Bug 15132 - Spurious characters in Japanese stylesheets
Summary: Spurious characters in Japanese stylesheets
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: stylesheets   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 14041 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 17:38 UTC by Telsa Gwynne
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 08:43:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file which gets errors from stylesheets when db2html is run (214 bytes, text/plain)
2000-08-02 17:40 UTC, Telsa Gwynne
no flags Details

Description Telsa Gwynne 2000-08-02 17:38:30 UTC
Tried a bunch of DocBook 3.1 files out via 'db2html' and
got this error for every single one. It was not present in
"stylesheets-0.10-2" (a Cygnus rpm which "tracks 
Norm's 1.44 stylesheets"). It is present in the beta, though:

jade:/usr/lib/sgml/stylesheets/nwalsh-modular/html/../common/dbl1ja.dsl:369:26:E:
unknown character name "U-524D\U-306E\U-30DA\U-30FC\U-30B8"
jade:/usr/lib/sgml/stylesheets/nwalsh-modular/html/../common/dbl1ja.dsl:378:26:E:
unknown character name "U-6B21\U-306E\U-30DA\U-30FC\U-30B8"

I gather these two lines are for generating navigation stuff:
369:   (make sequence (literal "&nav-prev;")))
378:   (make sequence (literal "&nav-next;"))

I am attaching a file of what passes for docbook which generates
this here on pinstripe but not with the 6.2 docbook tools. 

Note: db2html works fine: it just generates these errors. I suppose
it may not work in Japanese, of course...

Comment 1 Telsa Gwynne 2000-08-02 17:40:06 UTC
Created attachment 1835 [details]
file which gets errors from stylesheets when db2html is run

Comment 2 Tim Waugh 2000-08-04 08:53:40 UTC
Fixed in stylesheets-1.54.13rh-5.

Comment 3 Tim Waugh 2000-08-08 09:33:41 UTC
*** Bug 14041 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.