This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 151367 - gdm-binary constantly logging to syslog
gdm-binary constantly logging to syslog
Status: CLOSED DUPLICATE of bug 150745
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
: 153110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 06:02 EST by Paul Black
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 16:25:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Black 2005-03-17 06:02:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
gdm-binary is runing flat out trying to log to syslog:
Mar 17 10:57:51 zurich gdm[4246]: Can't set EGID to user GID
Mar 17 10:57:51 zurich last message repeated 9 times
Mar 17 10:57:51 zurich gdm[4246]: Can't set EGID to user GID
Mar 17 10:57:51 zurich gdm[4246]: Can't set EGID to user GID
Mar 17 10:57:55 zurich last message repeated 8762 times
Mar 17 10:57:55 zurich gdm[4246]: Can't set EGID to user GID
Mar 17 10:57:55 zurich last message repeated 71 times


Version-Release number of selected component (if applicable):
gdm-2.6.0.7-4

How reproducible:
Always

Steps to Reproduce:
1. Log in using gdm from default install


Actual Results:  gdm-binary constantly logging

Expected Results:  Wouldn't expect constant logging and use of CPU.

Additional info:
Comment 1 Aaron Kurtz 2005-03-17 06:36:56 EST
Paul, this was fixed in rawhide. "yum update gdm" makes it go away.
Comment 2 Paul Black 2005-03-17 07:11:26 EST
That's done the job. Cheers.
Comment 3 Carl Flarity 2005-03-19 00:09:09 EST
When I do "yum update gdm" it tells me I need to download keys for the packages
I want to install and install them. It says to do so with command "rpm --import
public.gpg.key". But when I give this command I get "error: public.gpg.key:
import read failed(-1)."  How do I get gdm to behave?
Comment 4 Andrew Gorges 2005-03-20 04:54:19 EST
(In reply to comment #3)
> When I do "yum update gdm" it tells me I need to download keys for the packages
> I want to install and install them. It says to do so with command "rpm --import
> public.gpg.key". But when I give this command I get "error: public.gpg.key:
> import read failed(-1)."  How do I get gdm to behave?
> 

One temporary solution is to open /etc/yum.conf and change the line:

gpgcheck=1

to

gpgcheck=0

then run yum update gdm.
Comment 5 Carl Flarity 2005-03-21 17:13:51 EST
Thanks. I was able to do the "yum update gdm" after setting gpgcheck=0 in
/etc/yum.conf and now gdm-binary is no longer taking nearly all the cpu cycles
as it constantly logs to syslog.

Hint to anyone else reading this work-around: Do NOT log into the GNOME desktop
gui. Instead, use an alternate console (Ctrl-Alt-F1) to log in and work in the
character-based console. Thus, gdm-binary doesn't run as you perform the update
and you'll have full use of the cpu. When done Ctrl-Alt-F7 returns you to the
GNOME desktop gui.
Comment 6 Ray Strode [halfline] 2005-04-10 10:53:33 EDT
*** Bug 153110 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Clasen 2005-04-21 16:25:00 EDT

*** This bug has been marked as a duplicate of 150745 ***

Note You need to log in before you can comment on or make changes to this bug.