Bug 151369 - LANG environment variable reset
LANG environment variable reset
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elena Zannoni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 06:24 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 09:05:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-03-17 06:24:06 EST
Description of problem:
LANG variable gets reset when running gdb.

Version-Release number of selected component (if applicable):
gdb-6.1post-1.20040607.43

How reproducible:
100%

Steps to Reproduce:

export LANG=zh_CN
gdb /usr/bin/gdb
b main
r
p (char*)getenv("LANG")
  
Actual results:
On rawhide, "en_GB.UTF-8" (my default locale) is displayed.

Expected results:
On FC3, "zh_CN" is displayed as expected.

Additional info:
Comment 1 Jens Petersen 2005-09-27 08:10:38 EDT
Hmm, when I try this on my fc4 box with gdb-6.3.0.0-1.21.x86_64, I get:

(gdb) p (char*) getenv("LANG")
zsh: segmentation fault  gdb /usr/bin/gdb
[petersen@localhost]~%
Message from syslogd@localhost at Tue Sep 27 21:08:47 2005 ...
localhost kernel: invalid operand: 0000 [2] SMP

Message from syslogd@localhost at Tue Sep 27 21:08:47 2005 ...
localhost kernel: invalid operand: 0000 [2] SMP

(virtual smp via HT: kernel-smp-2.6.12-1.1390_FC4.x86_64)
Comment 2 Tim Waugh 2005-09-27 09:05:21 EDT
Yeah, me too with kernel-2.6.12-1.1456_FC4.x86_64 and gdb-6.3.0.0-1.21.  

Works correctly, without even resetting LANG, with kernel-2.6.13-1.1574_FC5.i386
and gdb-6.3.0.0-1.65.

Looks like this is a case of "fixed in rawhide" for the original report, but
perhaps a separate report (against kernel?) is needed for the segmentation fault
issue.

Note You need to log in before you can comment on or make changes to this bug.