Bug 151384 - wrong sorting in the date column
wrong sorting in the date column
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 09:29 EST by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 11:33:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the evolution main window (195.76 KB, image/jpeg)
2005-03-17 09:31 EST, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2005-03-17 09:29:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Sorting the emails descending sorts not correctly: a mail received 02:00 PM is not sort after an email received 11:00 AM. I have attached a evolution window, and the  marked email is more recent than the email in the last row.

Version-Release number of selected component (if applicable):
evolution-2.0.4-1

How reproducible:
Always

Steps to Reproduce:
1.Receive one email in the morning, anotherone in the afternoon (AM and PM)
2.
3.
  

Actual Results:  the AM email is placed at the botton after the PM email.

Expected Results:  the correct placement.

Additional info:

I will attached a graphics showing what I mean.
Comment 1 Joachim Backes 2005-03-17 09:31:31 EST
Created attachment 112094 [details]
the evolution main window

Shows the wrong placement AM/PM
Comment 2 Dave Malcolm 2005-03-17 11:33:32 EST
Thanks for the report.

The issue here is that you have threading turned on, and I believe Evolution is
first organising the emails into trees based on mail threading, and then the
mails are sorted at each level of the tree according to date.

Hence the 2.44PM mail appears above the 11.09AM one since it is a descendent of
an earlier thread.

You can fix this by turning threading off with Ctrl-T.

If you have suggestions for improvements to the email view, they should be
reported to the authors of the program. Most upstream authors use a bug tracking
system like bugzilla, and more people who know the code will be looking at the
bug report there.

The upstream bug tracking system to use for Evolution is:
http://bugzilla.ximian.com/

Note You need to log in before you can comment on or make changes to this bug.