Bug 151385 - scrollkeeper-update seg faults during 'yum update'
scrollkeeper-update seg faults during 'yum update'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scrollkeeper (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
: 151446 151487 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 09:30 EST by Tom London
Modified: 2013-03-05 22:43 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.3.14-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 14:29:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2005-03-17 09:30:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Running Rawhide.

'yum update' on today's Rawhide, get the following failures:


Updating  : gnome-pilot                  ##################### [ 20/144]
/var/tmp/rpm-tmp.55621: line 7:  4015 Segmentation fault      scrollkeeper-update
error: %post(gnome-pilot-2.0.12-9.i386) scriptlet failed, exit status 139
  Updating  : gnome-media                  ##################### [ 23/144]
/var/tmp/rpm-tmp.47918: line 1:  4020 Segmentation fault      scrollkeeper-update
  Updating  : gthumb                       ##################### [ 24/144]
/var/tmp/rpm-tmp.46075: line 2:  4030 Segmentation fault      scrollkeeper-update
  Updating  : gnome-applets                ##################### [ 32/144]
/var/tmp/rpm-tmp.50142: line 2:  4044 Segmentation fault      scrollkeeper-update
  Updating  : gok                          ##################### [ 56/144]
/var/tmp/rpm-tmp.82614: line 2:  4083 Segmentation fault      scrollkeeper-update
  Cleanup   : gnome-media                  ##################### [ 76/144]
/var/tmp/rpm-tmp.37587: line 1:  4117 Segmentation fault      scrollkeeper-update
  Cleanup   : gok                          ##################### [118/144]
/var/tmp/rpm-tmp.65556: line 1:  4197 Segmentation fault      scrollkeeper-update
error: %postun(gok-1.0.1-2.i386) scriptlet failed, exit status 139




Version-Release number of selected component (if applicable):
scrollkeeper-0.3.14-4

How reproducible:
Always

Steps to Reproduce:
1. 'yum update'
2.
3.
  

Additional info:
Comment 1 Tom London 2005-03-17 09:38:42 EST
Additional info:

scrollkeeper-0.3.14-4 was on the 'update today' list of packages:
  Updating  : krb5-libs                    ##################### [  1/144]
  Updating  : scrollkeeper                 ##################### [  2/144]

So it was updated prior to faults listed above.
Comment 2 Todd Mokros 2005-03-17 13:14:09 EST
I saw the same problem.  Rebuilding the scrollkeeper rpm locally fixed it.
Comment 3 David Zeuthen 2005-03-17 13:35:17 EST
I can reproduce this; probably due to gcc4 rebuild. Looking at it. Todd, as you
said in comment 2 the local rebuild fixed it - was this with gcc 4.0?
Comment 4 David Zeuthen 2005-03-17 14:29:43 EST
Here is the SRPM with the fix (works for me with gcc v4)

 http://people.redhat.com/davidz/scrollkeeper-0.3.14-5.src.rpm

Will be available in Rawhide tomorrow.

David
Comment 5 David Zeuthen 2005-03-17 20:35:56 EST
*** Bug 151446 has been marked as a duplicate of this bug. ***
Comment 6 David Zeuthen 2005-03-18 10:29:18 EST
*** Bug 151487 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.