Bug 151416 - /usr/bin/script fails this is a descriptive summary
Summary: /usr/bin/script fails this is a descriptive summary
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 151417 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-17 18:26 UTC by DE
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 14:44:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description DE 2005-03-17 18:26:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
$ script
pt_chown: needs to be installed setuid `root'
openpty failed
Terminated
$ echo $?
143
$




Version-Release number of selected component (if applicable):
util-linux-2.11y-31.1

How reproducible:
Always

Steps to Reproduce:
1. As non-root user, invoke script
2. Verify error message
3. This is step number three
  

Actual Results:  Script command fails complaining about pt_chown needing to be setuid 'root'

Expected Results:  The command should have exited with a zero status and initiated a log file in the current working directory of each command the user types and terminal output for commands in a log file.  See script(1)


Additional info:



The bugzilla interface has a terrible searching interface.  However, for bugs listed under 'util-linux', this one was not listed.  Therefore I believe to the best of my knowledge that this is a new bug.

Comment 1 Suzanne Hillman 2005-03-17 19:12:33 UTC
*** Bug 151417 has been marked as a duplicate of this bug. ***

Comment 2 Karel Zak 2005-03-24 14:44:29 UTC
I can't reproduce it:

$ rpm -q util-linux
util-linux-2.11y-31.2
$ script
Script started, file is typescript

It looks you haven't mounted /dev/pts. Please, check it:

$ mount | grep devpts
none on /dev/pts type devpts (rw,gid=5,mode=620)


Note You need to log in before you can comment on or make changes to this bug.