Bug 151417 - /usr/bin/script fails this is a descriptive summary
/usr/bin/script fails this is a descriptive summary
Status: CLOSED DUPLICATE of bug 151416
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 13:27 EST by DE
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 14:12:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description DE 2005-03-17 13:27:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
$ script
pt_chown: needs to be installed setuid `root'
openpty failed
Terminated
$ echo $?
143
$




Version-Release number of selected component (if applicable):
util-linux-2.11y-31.1

How reproducible:
Always

Steps to Reproduce:
1. As non-root user, invoke script
2. Verify error message
3. This is step number three
  

Actual Results:  Script command fails complaining about pt_chown needing to be setuid 'root'

Expected Results:  The command should have exited with a zero status and initiated a log file in the current working directory of each command the user types and terminal output for commands in a log file.  See script(1)


Additional info:



The bugzilla interface has a terrible searching interface.  However, for bugs listed under 'util-linux', this one was not listed.  Therefore I believe to the best of my knowledge that this is a new bug.
Comment 1 Suzanne Hillman 2005-03-17 14:12:25 EST

*** This bug has been marked as a duplicate of 151416 ***

Note You need to log in before you can comment on or make changes to this bug.