Bug 151447 - Application behavior change after last up2date
Application behavior change after last up2date
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 21:01 EST by Warren Sturm
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 11:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Sturm 2005-03-17 21:01:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
The application, MythTV, which is linked with QT would allow the keyboard to be used to exit the application.  Since the upgrade it now takes a mouse click on the exit bar to accomplish this.  Before, one could hit either space bar or enter to exit after usining the cursor keys to position.  I recompiled mythtv but the same behavior is exhibited.

Version-Release number of selected component (if applicable):
qt-3.3.4-0.fc3.0

How reproducible:
Always

Steps to Reproduce:
1. Start up mythfrontend.
2. hit escape key to exit
3. position to Exit bar and hit space bar or enter key
  

Actual Results:  the application does not exit

Expected Results:  The application should exit

Additional info:

2005-03-17 18:54:40.432 mythfrontend version: 0.17.20050130-1 www.mythtv.org
2005-03-17 18:54:40.433 Enabled verbose msgs : important general
2005-03-17 18:54:40.714 Switching to square mode (Titivillus)
2005-03-17 18:54:41.339 Registering Internal as a media playback plugin.
2005-03-17 18:54:41.378 Joystick disabled.
2005-03-17 18:54:46.644 Connecting to backend server: 127.0.0.1:6543 (try 1 of 5)
2005-03-17 18:54:46.651 Using protocol version 14

The Confirm Exit box needs to be checked.  Unchecked, mythfrontend will behave as expected.
Comment 1 Ngo Than 2005-04-14 11:04:40 EDT
i cannot verify this problem in mythfrontend, but i don't see the problem
in several qt/kde applications.
Comment 2 jspot 2005-05-15 11:28:58 EDT
For what its worth, many other people (including myself) are still experiencing 
this problem. Please see: http://www.gossamer-
threads.com/lists/mythtv/users/129137?do=post_view_threaded

Note You need to log in before you can comment on or make changes to this bug.