Bug 151459 - No system-config-display hardware solutions for very recent 15" Powerbook
No system-config-display hardware solutions for very recent 15" Powerbook
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-17 23:00 EST by Drew Bertola
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 10:22:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf for Powerbook 15" 1280x854 w/ Radeon 9600/9700 (from recent Ubuntu Live CD) (3.29 KB, text/plain)
2005-03-17 23:00 EST, Drew Bertola
no flags Details
Xorg.0.log file (in entirety) from a successful session on powerbook 15" (32.15 KB, text/plain)
2005-04-12 00:16 EDT, Drew Bertola
no flags Details

  None (edit)
Description Drew Bertola 2005-03-17 23:00:09 EST
Description of problem:
X looks terrible after fresh install, and no system-config-display hardware
settings are available for brand new 15" Powerbook w/ 1280x854 screen and Radeon
Mobility 9700.

Version-Release number of selected component (if applicable):


How reproducible:
Fresh FC4-T1 install w/ X (and gdm/Gnome/etc).  

Steps to Reproduce:
1. Install w/ X, Gnome, system-config-display
2. Reboot. (Wrong resolution so gdm/gnome look like crap.
3. Try to resolve w/ system-config-display... 
  
Actual results:
system-config-display has no hardware option listed for Radeon Mobility 9700 or
for Apple 15" Powerbook LCD (1280x854) or a generic equivalent.

Expected results:
Anaconda would have probed and found the hardware and automatically set it up. 
system-config-display would have listed this hardware since it's not obscure and
does work well with installed display drivers.

Additional info:
I copied an xorg.conf from a recent Ubuntu Live CD and everything worked fine. 
I'll attach this file.
Comment 1 Drew Bertola 2005-03-17 23:00:09 EST
Created attachment 112117 [details]
xorg.conf for Powerbook 15" 1280x854 w/ Radeon 9600/9700 (from recent Ubuntu Live CD)
Comment 2 Drew Bertola 2005-03-18 19:21:07 EST
Here's what lspci says regarding the graphics controller:

00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon
9600 M10]
Comment 3 Mike A. Harris 2005-04-11 06:21:20 EDT
Does ubuntu patch the X server with special modelines for this hardware?
I don't see any manually supplied modelines in your X server config file
above, however this is not a "standard" video mode supported by the
X server.

We need you to provide the video modeline that the X server is using.
You can get that from the X server log file.


This really should be reported to X.Org directly however at:
   http://bugs.freedesktop.org

That way it gets fixed at the source, rather than each distribution adding
distro-specific kludges.

Comment 4 Drew Bertola 2005-04-11 08:05:20 EDT
I think you're over shooting.  As reported, I didn't use anything from ubuntu
other than it's xorg.conf.  Everything else was stock fc4t1-ppc.

fc4t1 didn't provide a working xorg.conf because it doesn't recognize the
hardware when probed.  There was no patching necessary and X works great when
this configuration is applied.
Comment 5 Mike A. Harris 2005-04-11 08:46:55 EDT
Ah, there seems to be a misunderstanding.

Our configuration tools configure the native video drivers.  We do not
(to my knowledge) ever use framebuffer except on IBM Power hardware
(in lieu of native drivers).

This resolution will not work out of the box with the native driver
unless the modeline is specified in the config file, or compiled into
the X server.

When you use UseFBDev, the kernel itself sets the video mode, and X has
nothing to do with it at all.

Your (the ubuntu) solution is a workaround, not a real fix for the real
problem.  Feel free to use the UseFbDev solution as a workaround if it
does the job well enough for you, but that is not the real fix.

The real fix is to report this to X.org and have them add the video
modeline directly to the server for this non-standard display size,
as it is likely to get more popular.  This way the ugly fbdev hack can
be avoided, and the native video driver is in control of the display
resolution.

Once you've filed a bug report in X.Org bugzilla, if you paste the URL
here, we will track the issue and when fixes are checked into CVS for this
issue, we will review them for consideration.

Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.
Comment 6 Drew Bertola 2005-04-12 00:16:09 EDT
Created attachment 113008 [details]
Xorg.0.log file (in entirety) from a successful session on powerbook 15"

If only for future readers, attached is a copy of my Xorg.0.log file.
Comment 7 Drew Bertola 2005-04-12 03:32:27 EDT
OK, I filed a report on https://bugs.freedesktop.org

https://bugs.freedesktop.org/show_bug.cgi?id=2989
Comment 8 Mike A. Harris 2005-04-12 10:22:02 EDT
Thanks.

Setting status to "UPSTREAM" for tracking.

Note You need to log in before you can comment on or make changes to this bug.