Bug 151466 - [OOo][gcj] failure under ppc which is ok under i386 with gcj -shared -findirect-dispatch -fjni
[OOo][gcj] failure under ppc which is ok under i386 with gcj -shared -findire...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 05:14 EST by Caolan McNamara
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.0.0-0.35
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 15:57:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bziped jar (2.79 MB, application/x-bzip)
2005-03-18 05:19 EST, Caolan McNamara
no flags Details

  None (edit)
Description Caolan McNamara 2005-03-18 05:14:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041220

Description of problem:
Take attached xalan.jar
under i386
gcj -shared -findirect-dispatch -fjni -o xalan.jar.so xalan.jar
is error-free
under ppc
gcj -shared -findirect-dispatch -fjni -o xalan.jar.so xalan.jar
results in 
/tmp/cc3zp5Il.s: Assembler messages:
/tmp/cc3zp5Il.s:2582571: Error: operand out of range (0xffffffffffff7ee0 is not between 0xffffffffffff8000 and 0x0000000000007fff)


Version-Release number of selected component (if applicable):
gcc

How reproducible:
Always

Steps to Reproduce:
1. gcj -shared -findirect-dispatch -fjni -o xalan.jar.so xalan.jar


Actual Results:  /tmp/cc3zp5Il.s: Assembler messages:
/tmp/cc3zp5Il.s:2582571: Error: operand out of range (0xffffffffffff7ee0 is not between 0xffffffffffff8000 and 0x0000000000007fff)

Expected Results:  something nice

Additional info:

apparently fine under i386
Comment 1 Caolan McNamara 2005-03-18 05:20:01 EST
Created attachment 112120 [details]
bziped jar
Comment 2 Jakub Jelinek 2005-03-18 06:27:32 EST
Reproduced, will look at it, looks like ppc backend bug.

Can reproduce it with just
CLASSPATH=xalan.jar gcj -shared -findirect-dispatch -fjni -o xalan.jar.so
XPathLexer.class
(where XPathLexer.class is extracted from xalan.jar).
Just curious, why aren't you using -O2?
Without -O2, I'd say it doesn't help you much that you compile the classes
natively...
Comment 3 Jakub Jelinek 2005-03-21 15:57:09 EST
Shouldbe fixed in gcc-4.0.0-0.35.

Note You need to log in before you can comment on or make changes to this bug.