Bug 151472 - Anaconda kickstart: DNS server is not in resol.conf when using interactive option
Anaconda kickstart: DNS server is not in resol.conf when using interactive op...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-03-18 07:18 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-594
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 11:28:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2005-03-18 07:18:30 EST
When "interactive" option is filled in kickstart file, the installed system has
no DNS server in /etc/resolv.conf file (ie. no nameserver line is included) when
configured via DHCP. Because this, %post script fail when using DNS names
instead of IP adresses.

The nameserver line is properly filled up in the resolv.conf file when
"interactive" is not used in kickstart file. I checked it by ALT-F2 shell prompt
and chrooting to the new, freshly installed system before final restart.

I have working DHCP server in my network and we have no problem with other
machines. KS file: http://ftp.pslib.cz/pub/users/Milan.Kerslager/ks/ict-c4gui.ks
Comment 1 Chris Lumens 2005-03-22 10:59:58 EST
Committed on rawhide for further testing, looking at when to merge into RHEL4.
Comment 9 Red Hat Bugzilla 2005-10-05 11:28:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-594.html

Note You need to log in before you can comment on or make changes to this bug.