Bug 151477 - Punjabi Keyboard Problems
Punjabi Keyboard Problems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: im-sdk (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 151478 151480 (view as bug list)
Depends On:
Blocks: 155520 156322
  Show dependency treegraph
 
Reported: 2005-03-18 08:16 EST by Jassy Phulewala
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-683
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 12:46:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Phonetic Keyboard Layout with required changes (978 bytes, text/plain)
2005-04-20 04:09 EDT, A S Alam
no flags Details
GURMUKHI/phonetic.utf (967 bytes, text/plain)
2005-04-20 22:28 EDT, Jens Petersen
no flags Details
Phonetic Keyboard Update File (963 bytes, text/plain)
2005-05-02 01:23 EDT, A S Alam
no flags Details
update for combined characters (976 bytes, application/octet-stream)
2005-05-02 03:00 EDT, A S Alam
no flags Details

  None (edit)
Description Jassy Phulewala 2005-03-18 08:16:21 EST
Description of problem:
There are One Punjabi Character is missing from Keyboard. Punjabi Phonetic has
no key for U0A23.  English  Character  R is there which  has no meaning in
Punjabi keyboard layout.

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. Open  gedit.
2. Select input  Language as pa_IN. UTF-8
3.  there is no  keystoke for U0A23, b
4.  Press Shift + R, 
5.  Press  shift + | 
Actual results:
1) R
2)   | (English character)
Expected results:
1)  "੍ਰ" 
2)  "।" (hindi danda)  
Additional info:
Comment 2 Suzanne Hillman 2005-03-18 11:10:16 EST
*** Bug 151480 has been marked as a duplicate of this bug. ***
Comment 3 Suzanne Hillman 2005-03-18 11:10:17 EST
*** Bug 151478 has been marked as a duplicate of this bug. ***
Comment 5 A S Alam 2005-04-20 04:08:33 EDT
Hi, 

I make phonetic.txt file for these problem and Keyboard layout is updated 
as
http://punjabirc.tiet.ac.in/pedict/amrlipi1.html,

only two characters are missed which are in unicode. I m attaching,

thanks
alam
Comment 6 A S Alam 2005-04-20 04:10:01 EDT
Created attachment 113392 [details]
Phonetic Keyboard Layout with required changes

Phonetic Keyboard Layout with required changes
Comment 8 Jens Petersen 2005-04-20 21:37:00 EDT
Can you tell me which are the two missing keys in the map?
Comment 9 Jens Petersen 2005-04-20 21:38:19 EDT
If you could make the changes in the current file and attach the diff
as a patch that would be great. :)
Comment 10 Jens Petersen 2005-04-20 22:28:08 EDT
Created attachment 113455 [details]
GURMUKHI/phonetic.utf

Here is the current upstream Punjabi phonetic keymap.
If you could make the changes directly to it and attach
the updated file here, that would be perfect, thanks. :)
Comment 12 A S Alam 2005-05-02 01:23:48 EDT
Created attachment 113915 [details]
Phonetic Keyboard Update File

Updated Phonetic Keyboard File
Comment 13 A S Alam 2005-05-02 03:00:41 EDT
Created attachment 113916 [details]
update for combined characters

combine characters are updated for Punjabi File
Comment 14 Jens Petersen 2005-05-02 04:09:56 EDT
Thank you very much.

[Committed this upstream in svn r2604 in trunk and r2606 in r12_2.]
Comment 18 Jens Petersen 2005-07-28 10:49:30 EDT
im-sdk-12.1-13.EL.2 has been built for U2 to address this issue.
Comment 20 Lawrence Lim 2005-09-14 01:42:43 EDT
U0A23 is at US keyboard X (phonetic)
Comment 22 Red Hat Bugzilla 2005-10-05 12:46:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-683.html

Note You need to log in before you can comment on or make changes to this bug.