Bug 151490 - Anaconda does not create Xen entries in grub.conf
Anaconda does not create Xen entries in grub.conf
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 154819 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 10:35 EST by Keith Sharp
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-17 08:23:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Sharp 2005-03-18 10:35:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050309 Epiphany/1.5.8

Description of problem:
After a clean, full, install of FC4T1 the only entries in grub.conf are for the normal FC uniprocessor and multiprocessor kernels.  No entries for the Xen dom0 kernel have been created.

Version-Release number of selected component (if applicable):
anaconda-10.2.0.27-1

How reproducible:
Always

Steps to Reproduce:
1. Do a clean everything install of FC4T1
2. Reboot and look at entries in grub.conf
3.
  

Actual Results:  Only entries are for normal FC kernels.

Expected Results:  There should been an entry to allow booting into the Xen dom0 kernel.

Additional info:

Paul Iadonisi reported on fedora-test:

"Hmm, yes, it is probably a bug.  I saw this, too.  Could be an
anaconda bug, though, because running the commands in the kernel-xen0
postinstall script by hand works."
Comment 1 Keith Sharp 2005-03-18 11:25:27 EST
I have just updated the kernel-xen* packages using yum and grub.conf was updated
correctly.
Comment 2 Jeremy Katz 2005-03-21 13:37:01 EST
Committed a workaround so that Xen kernels don't get installed by default.  Will
hopefully have the full fix before FC4 release.
Comment 3 Thomas M Steenholdt 2005-03-22 01:58:35 EST
Why not do do this "correctly" by having a "Virtualization" entry under
"Servers" in the package group selection screen? If somebody chooses to install
the Xen kernels, install the packages as normal, allowing them to add stuff to
grub.conf.
Same thing for an everything install
Comment 4 Kevin Maguire 2005-03-26 05:50:12 EST
Hi

I dont see any kernel-xen* packages at all anymore?

After a "yum update"

$ rpm  -q xen kernel
xen-2-20050308
kernel-2.6.11-1.1202_FC4

where can  I now get the Xen dom0 kernel?

Or, have I just misunderstood something?
?

Kevin
Comment 5 Jeremy Katz 2005-04-14 10:17:15 EDT
*** Bug 154819 has been marked as a duplicate of this bug. ***
Comment 6 Keith Sharp 2005-04-14 12:10:41 EDT
I have just done a clean install of FC4T2 and the fix of not installing the Xen
kernels appears to have worked.  The problem is that the -devel packages for the
Xen kernels have been installed:

$ rpm -qa kernel\* xen
kernel-xenU-devel-2.6.11-1.1226_FC4
kernel-smp-2.6.11-1.1226_FC4
kernel-xen0-devel-2.6.11-1.1226_FC4
kernel-devel-2.6.11-1.1226_FC4
kernel-doc-2.6.11-1.1226_FC4
kernel-2.6.11-1.1226_FC4
kernel-smp-devel-2.6.11-1.1226_FC4
xen-2-20050403

Surely the -devel packages should have been skipped as well?
Comment 7 Rahul Sundaram 2005-11-17 08:23:41 EST
Now that Fedora Core 4 has been replaced, I am closing this as CANTFIX. For the
subsequent release, better Xen integration is planned

http://fedoraproject.org/wiki/Anaconda/XenInstall

Note You need to log in before you can comment on or make changes to this bug.