Bug 151505 - SATA controller recognized as ata_piix i.s.o. ahci
SATA controller recognized as ata_piix i.s.o. ahci
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 14:00 EST by Aad Rijnberg
Modified: 2015-01-04 17:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 17:51:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aad Rijnberg 2005-03-18 14:00:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
I can not use the SATA-drive in my Dell Dimension 8400 without manual intervention. In /etc/sysconfig/hwconf the device is recognized as:
class: OTHER
bus: PCI
detached: 0
driver: ata_piix
desc: "Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA Controller"
vendorId: 8086
deviceId: 2652
subVendorId: 1028
subDeviceId: 0177
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 1f
pcifn:  2
After start-up I see that the ata_piix module is loaded, but I can not mount the (windows partition of the) harddisk. If I unload the driver, and manually load the ahci-driver, then mounting is possible and I can access files on that partition. I already replaced in /etc/modprobe.conf the line:
  alias scsc_hostadapter ata_piix
by: 
  alias scsc_hostadapter ahci
but then at boot BOTH ata_piix AND ahci are loaded, and as a result I can not access the drive. After I unload the ata_piix module, I can again access the drive.
I prefer to leave the BIOS-setting for the SATA mode untouched (RAID/AHCI), so that I do not have to re-install Windoze. 

Could it be that Kudzu currently does not take this BIOS-setting into account and activates the wrong driver (at least for my system)?

Version-Release number of selected component (if applicable):
kudzu-1.1.95-1

How reproducible:
Always

Steps to Reproduce:
1. Boot the system from my PATA-drive on the IDE bus (prim. master)
2. lsmod shows that ata_piix is loaded
3. rmmod ata_piix followed by modprobe ahci loads the ahci module
  

Actual Results:  After step 2. mounting of the windows partition on the SATA drive is not possible.

Expected Results:  After step 3. mounting of the windows partition on the SATA drive succeeds.

Additional info:

As I understand it, the Dell Dimension 8400 can be used in different SATA modes. Maybe you can add detection for those modes in Kudzu and activate the proper driver for the different modes.
Comment 1 Bill Nottingham 2005-03-18 14:16:03 EST
Both kernel drivers claim the device. AFAIK, there is no way to determine the
setting of the device.
Comment 2 Dave Jones 2005-07-15 16:40:21 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Aad Rijnberg 2005-07-18 17:20:25 EDT
I have updated to this version, restored the alias scsi_hostadapter to atapiix
in /etc/modprobe.conf, installed the ntfs kernel module, and rebooted. It
appeared that the SATA-drive was recognized and I could mount it. So it seems
that the problem is fixed. Thanks!

I also checked in FC4, because that is what I currently use. There it also
worked like a charm (/etc/modprobe.conf defines the alias scsi_hostadapter as
atapiix and /etc/sysconfig/hwconf also sees it as atapiix).
Comment 4 Aad Rijnberg 2005-07-18 17:21:28 EDT
I have updated to this version, restored the alias scsi_hostadapter to atapiix
in /etc/modprobe.conf, installed the ntfs kernel module, and rebooted. It
appeared that the SATA-drive was recognized and I could mount it. So it seems
that the problem is fixed. Thanks!

I also checked in FC4, because that is what I currently use. There it also
worked like a charm (/etc/modprobe.conf defines the alias scsi_hostadapter as
atapiix and /etc/sysconfig/hwconf also sees it as atapiix).
Comment 5 Aad Rijnberg 2005-07-18 17:23:28 EDT
Sorry for the double post. As I was asked to log in first I thought that I had
to retype the text, but then after sending it the second time, I saw it was
duplicated.

Note You need to log in before you can comment on or make changes to this bug.