Bug 151540 - up2date fails to start with reference to XMLRPC foo
up2date fails to start with reference to XMLRPC foo
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 20:05 EST by Laz Davila
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 22:16:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laz Davila 2005-03-18 20:05:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
System was registered as RHEL 3.0 on RHN.
Installed RHEL 4.0. Removed system registration from RHN.
Registered system running 4.0 with RHN.
up2date worked for about a week fine.

But, now am unable to start up2date, but there is no apparent reason.
Running up2date from command line results in:

[root@server ~]# up2date
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
Name or service not known

Attempting to re-register with RHN results in:

[root@server ~]# rm /etc/sysconfig/rhn/systemid
rm: remove regular file `/etc/sysconfig/rhn/systemid'? y
[root@server ~]# up2date --register
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 442, in onLoginPageNext
    ret = self.loginPageApply()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 148, in loginPageApply
    self.getCaps()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 90, in getCaps
    caps = rhnreg.getCaps()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 216, in getCaps
    rpcServer.doCall(s.registration.welcome_message)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 319, in doCall
    raise up2dateErrors.CommunicationError(e.args[1])
up2date_client.up2dateErrors.CommunicationError: Error communicating with server. The message was:
Name or service not known

Other things tried:
 - ensuring can look up server, via dig/host/telnet (all work fine)
 - ensuring have access to rhn (via login) - works fine
 - resetting rpm database, but this is working fine too.

Any thoughts?

Version-Release number of selected component (if applicable):
up2date-4.4.5-1

How reproducible:
Always

Steps to Reproduce:
1. run up2date from command line
2.
3.
  

Actual Results:  https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
https://xmlrpc.rhn.redhat.com/XMLRPC foo
Name or service not known

Expected Results:  Read package list and then update

Additional info:
Comment 1 Laz Davila 2005-03-18 22:16:14 EST
Closed bug report.
This is not a bug of up2date.
Further investigation revealed that dig/nslookup/host all correctly resolved 
xmlrpc.rhn.redhat.com
But ping/wget would not resolve it.

Root cause of problem was a blackout, which left nscd caches corrupt.
Resolved by clearing the hosts cache, via:
# nscd -i hosts

If this resolves anyone else's problems, you may want to also invalidate the 
caches of other important files for good measure:
# nscd -i passwd
# nscd -i group

Regards,
Laz.

Note You need to log in before you can comment on or make changes to this bug.