Bug 151544 - pxe install with tg3 driver fails with rhel4
pxe install with tg3 driver fails with rhel4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-18 21:45 EST by Christopher P Johnson
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-13 11:29:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher P Johnson 2005-03-18 21:45:38 EST
Description of problem:

On Sun Microsystems Inc. v20z/v40z opteron servers, rhel4 is no
longer able to successfully perform pxe installation with the tg3 driver
with gbe switches (details of the broadcom chip revision below). Various
popular Cisco and Netgear GBE switches were tested.

Note that pxe installation with rhel3u4 does work with the identical setups.
The workaround is to install with a 100mbit switch or hub.

The failure scenario is that DHCP requests fail, on either interface
(eth0 or eth1). Anaconda returns to the network interface configuration
screen over and over. (Once in a long while, retrying the DHCP configuration
succeeds). This happens whether or not a kickstart device and file are
specified.

Apparently it is well known that anaconda brings the network interface(s)
up several times in rapid succession during a pxe installation boot. I believe
there was converstation about a 'nicdelay' boot parameter to control the
speed of reconfiguration, to allow autonegotiation to succeed.


Version-Release number of selected component (if applicable):

02:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5703X Gigabit
Ethernet (rev 02)
        Subsystem: Newisys, Inc.: Unknown device 0020
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+
Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (16000ns min), Cache Line Size 10
        Interrupt: pin A routed to IRQ 185
        Region 0: Memory at e5800000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [40] PCI-X non-bridge device.
                Command: DPERE- ERO- RBC=2 OST=0
                Status: Bus=2 Dev=2 Func=1 64bit+ 133MHz+ SCD- USC-, DC=simple,
DMMRBC=2, DMOST=0, DMCRS=1, RSCEM-
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [50] Vital Product Data
        Capabilities: [58] Message Signalled Interrupts: 64bit+ Queue=0/3 Enable-
                Address: dffffffffffffff8  Data: fff6
00: e4 14 a7 16 46 01 b0 02 02 00 00 02 10 40 00 00
10: 04 00 80 e5 00 00 00 00 00 00 00 00 00 00 00 00
20: 00 00 00 00 00 00 00 00 00 00 00 00 c2 17 20 00
30: 00 00 00 00 40 00 00 00 00 00 00 00 05 01 40 00
40: 07 48 08 00 11 02 43 04 01 50 02 c0 00 20 00 64
50: 03 58 fc 00


How reproducible:

pxe install a Sun Microsystems v20z/v40z with a gbe switch (Cisco, Netgear).

Additional info:

Note that sometimes it is possible to specify a static ip address, and
continue the installation. However this does not always succeed.
Comment 1 John W. Linville 2005-04-12 09:45:34 EDT
Is STP enabled on the switch ports?  If so, please try with STP disabled. 
 
Also, please try with the kernels available here: 
 
 http://people.redhat.com/linville/kernels/rhel4/ 
 
They include an update to the tg3 driver.  It can't hurt to try with the 
latest version. :-) 
 
Please try the actions above and report the results.  Thanks! 
Comment 2 John W. Linville 2005-05-13 11:29:04 EDT
Closed due to lack of response.  Please reopen with requested information if 
the problem persists.  Thanks! 

Note You need to log in before you can comment on or make changes to this bug.