Bug 151576 - gst-register-0.8 segmentation faults upon executing
gst-register-0.8 segmentation faults upon executing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-19 21:51 EST by Jed Cousin
Modified: 2013-03-13 00:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-23 11:57:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The actual results of running gst-register-0.8 (1.76 KB, text/plain)
2005-03-19 21:55 EST, Jed Cousin
no flags Details

  None (edit)
Description Jed Cousin 2005-03-19 21:51:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
gnome-volume-control segmentation faults upon running.  When I try to run it via Applications Menu --> Sound & Video --> Volume Control, I receive this error dialog:
"Registry is not present or it is corrupted, please update it by running gst-register"

The registry is located at:  /var/cache/gstreamer-0.8/registry-i386.xml

Upon running /usr/bin/gst-register-0.8, I receive the following segmentation fault:
Added plugin gsttags with 1 feature.
/usr/bin/gst-register-0.8: line 3:  5777 Segmentation fault      $x

Version-Release number of selected component (if applicable):
gstreamer-0.8.9-4

How reproducible:
Always

Steps to Reproduce:
1.  Open a terminal
2.  Run /usr/bin/gst-register-0.8
3.  gst-register-0.8 should seg fault

Actual Results:  Attached

Expected Results:  gst-register-0.8 should properly rebuild /var/cache/gstreamer-0.8/registry-i386.xml -- thus allowing gnome-volume-control to properly run.

Additional info:
Comment 1 Jed Cousin 2005-03-19 21:55:07 EST
Created attachment 112154 [details]
The actual results of running gst-register-0.8
Comment 2 John (J5) Palmieri 2005-03-22 18:36:29 EST
Works for me in the latest rawhide.  What version of gstreamer-plugins do you
have installed?
Comment 3 Jed Cousin 2005-03-22 19:04:46 EST
gstreamer-plugins is version 0.8.7-3.
Comment 4 Jed Cousin 2005-03-22 20:15:38 EST
It appears that a good chunk of my X-server was borked.  I'm not sure if it's
the hard drive or the HTTP install I used to install FC4T1.  Xorg's GLX module
refused to load for the binary nvidia drivers.  

I downloaded all of the installed Xorg RPMs and reinstalled them.  Now the GLX
module will successfully load and gst-streamer-0.8 completes the registry of
installed gstreamer plugins.  

Being able to run gnome-volume-control is another side-effect of the Xorg
reinstall.  This had refused to work since FC4T1 was installed.

Note You need to log in before you can comment on or make changes to this bug.