Bug 151581 - Broken package dependency
Broken package dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fortune-mod (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Sheltren
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-20 01:11 EST by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-20 23:26:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-03-20 01:11:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
# rpm -U fortune-mod-1.99.1-2.i386.rpm
error: Failed dependencies:
        librecode.so.0 is needed by fortune-mod-1.99.1-2.i386

# apt-get install fortune-mod
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  fortune-mod: Depends: librecode.so.0 but it is not installable
E: Broken packages


Version-Release number of selected component (if applicable):
fortune-mod-1.99.1-2

How reproducible:
Always

Steps to Reproduce:
# rpm -U fortune-mod-1.99.1-2.i386.rpm
error: Failed dependencies:
        librecode.so.0 is needed by fortune-mod-1.99.1-2.i386


Additional info:
Comment 1 Michael Schwendt 2005-03-20 06:04:35 EST
$ rpm --redhatprovides librecode.so.0
recode-3.6-13
$ cat /etc/fedora-release 
Fedora Core release 3 (Heidelberg)

But the fortune-mod packages released into Fedora Extras Development have the
same version-release as those for Fedora Extras 3. That's a bug.
Comment 2 Ralf Corsepius 2005-03-20 23:26:03 EST
My fault. As side-effect of experimenting with yum and apt, I managed to break
my local apt repositories.

Sorry for the confusion.

Note You need to log in before you can comment on or make changes to this bug.