Bug 151601 - FC3 fails to detect my floppy
FC3 fails to detect my floppy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-20 13:25 EST by petri.poyhonen
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-26 03:44:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description petri.poyhonen 2005-03-20 13:25:05 EST
Description of problem:

With my newly installed FC3 I cannot use the floppy disk.

Version-Release number of selected component (if applicable):


How reproducible:
consistently present.

Steps to Reproduce:
1. install FC3
2. try to mount floppy
3.
  
Actual results:
[petri@Volterra ~]$ mount /mnt/floppy
mount: can't find /mnt/floppy in /etc/fstab or /etc/mtab

Expected results:


Additional info:
[petri@Volterra ~]$ cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/hdc                /media/cdrecorder       auto   
pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed 0 0

[petri@Volterra ~]$ cat /etc/sysconfig/hwconf
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Triones Technologies, Inc. HPT366/368/370/370A/372"
vendorId: 1103
deviceId: 0004
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 13
pcifn:  1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Triones Technologies, Inc. HPT366/368/370/370A/372"
vendorId: 1103
deviceId: 0004
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 13
pcifn:  0
-
class: OTHER
bus: PCI
detached: 0
driver: emu10k1-gp
desc: "Creative Labs SB Live! MIDI/Game Port"
vendorId: 1102
deviceId: 7002
subVendorId: 1102
subDeviceId: 0020
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  d
pcifn:  1
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp. 82371AB/EB/MB PIIX4 ACPI"
vendorId: 8086
deviceId: 7113
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  7
pcifn:  3
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp. 82371AB/EB/MB PIIX4 ISA"
vendorId: 8086
deviceId: 7110
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  7
pcifn:  0
-
class: OTHER
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge"
vendorId: 8086
deviceId: 7191
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  1
pcifn:  0
-
class: OTHER
bus: PCI
detached: 0
driver: agpgart
desc: "Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge"
vendorId: 8086
deviceId: 7190
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  0
pcifn:  0
-
class: OTHER
bus: USB
detached: 0
driver: unknown
desc: "Linux 2.6.9-1.667 uhci_hcd UHCI Host Controller"
usbclass: 9
usbsubclass: 0
usbprotocol: 0
usbbus: 1
usblevel: 0
usbport: 0
usbdev: 1
vendorId: 0000
deviceId: 0000
usbmfr: Linux 2.6.9-1.667 uhci_hcd
usbprod: UHCI Host Controller
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: 8139too
desc: "Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+"
network.hwaddr: 00:00:21:11:4F:2B
vendorId: 10ec
deviceId: 8139
subVendorId: 10ec
subDeviceId: 8139
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  b
pcifn:  0
-
class: MOUSE
bus: PSAUX
detached: 0
device: input/mice
driver: generic3ps/2
desc: "ImExPS/2 Logitech Explorer Mouse"
-
class: AUDIO
bus: PCI
detached: 0
driver: snd-emu10k1
desc: "Creative Labs SB Live! EMU10k1"
vendorId: 1102
deviceId: 0002
subVendorId: 1102
subDeviceId: 8040
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  d
pcifn:  0
-
class: CDROM
bus: IDE
detached: 0
device: hdc
driver: ignore
desc: "R/RW 4x4x24"
-
class: VIDEO
bus: PCI
detached: 0
driver: Card:NVIDIA GeForce 2 MX (generic)
desc: "nVidia Corporation NV11 [GeForce2 MX/MX 400]"
vendorId: 10de
deviceId: 0110
subVendorId: 10b0
subDeviceId: 0002
pciType: 1
pcidom:    0
pcibus:  0
pcidev: 11
pcifn:  0
-
class: FLOPPY
bus: MISC
detached: 1
device: fd0
driver: unknown
desc: "3.5" 1.44MB floppy drive"
-
class: HD
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "SAMSUNG SP0411N"
physical: 4047/16/255
logical: 16383/255/63
-
class: KEYBOARD
bus: PSAUX
detached: 0
driver: ignore
desc: "AT Translated Set 2 keyboard"
-
class: USB
bus: PCI
detached: 0
driver: uhci-hcd
desc: "Intel Corp. 82371AB/EB/MB PIIX4 USB"
vendorId: 8086
deviceId: 7112
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  7
pcifn:  2
-
class: IDE
bus: PCI
detached: 0
driver: unknown
desc: "Intel Corp. 82371AB/EB/MB PIIX4 IDE"
vendorId: 8086
deviceId: 7111
subVendorId: 0000
subDeviceId: 0000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  7
pcifn:  1

- - - - - 
Apparently the floppy has been detected by kudzu.  What surprises me is that for
the floppy the value of "detached" attribute is 1 as for all other devices it is
0.  What does this indicate ?

It also surprises me that the CD-RW device does not appear on this list.

I have successfully installed FC3 from this CD-RW.

What may be wrong ?

I have tried manually adding a row for floppy:

/dev/fd0 /mnt/floppy  auto   noauto,owner  0  0

With these changes an attempt to mount results in a message reporting that this
is not a blockdevice.

Any proposals ?

Petri
Comment 1 Bill Nottingham 2005-03-22 23:14:18 EST
Is the floppy driver loaded? Does the device node exist?
Comment 2 petri.poyhonen 2005-03-24 11:44:33 EST
floppy driver is loaded with an MSDOS disk.

this is what I can find at /dev:

[petri@Volterra ~]$ cd /dev
[petri@Volterra dev]$ ls fd*
fd0        fd0h1200  fd0h1660  fd0h720   fd0u1440  fd0u1760  fd0u3520  fd0u820
fd0CompaQ  fd0h1440  fd0h360   fd0H720   fd0u1660  fd0u1840  fd0u360   fd0u830
fd0d360    fd0H1440  fd0H360   fd0h880   fd0u1680  fd0u1920  fd0u3840
fd0D360    fd0h1476  fd0h410   fd0u1040  fd0u1722  fd0u2880  fd0u720
fd0D720    fd0h1494  fd0h420   fd0u1120  fd0u1743  fd0u3200  fd0u800

fd:
0  1  2  3

Comment 3 Bill Nottingham 2005-03-24 13:40:55 EST
Any error messages from the kernel (check the output of 'dmesg') after you try
to mount /dev/fd0?
Comment 4 petri.poyhonen 2005-03-24 14:43:39 EST
[petri@Volterra ~]$ mount /dev/fd0
mount: can't find /dev/fd0 in /etc/fstab or /etc/mtab

[petri@Volterra ~]$ cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/hdc                /media/cdrecorder       auto   
pamconsole,exec,noauto,fscontext=system_u:object_r:removable_t,managed 0 0
Comment 5 petri.poyhonen 2005-03-24 14:49:10 EST
No new messages reported by /bin/dmesg after failing mount tried.
Comment 6 Bill Nottingham 2005-03-24 14:53:31 EST
What about:

mount /dev/fd0 /mnt

(or some other temporary directory)
Comment 7 petri.poyhonen 2005-03-25 09:56:17 EST
Kernel messages from boot time include:

[petri@Volterra ~]$ /bin/dmesg | grep fd0
Floppy drive(s): fd0 is 1.44M
[petri@Volterra ~]$ /bin/dmesg | grep floppy
ide-floppy driver 0.99.newide

Last messages reported by dmesg.  As you can see below, failing attempts to
mount /dev/fd0 or /mnt do not produce new kernel messages.

[petri@Volterra ~]$ /bin/dmesg | tail
ip_tables: (C) 2000-2002 Netfilter core team
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
pnp: Device 00:09 activated.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
lp0: using parport0 (interrupt-driven).
lp0: console ready
eth0: no IPv6 routers present

[petri@Volterra ~]$ mount /dev/fd0
mount: can't find /dev/fd0 in /etc/fstab or /etc/mtab

[petri@Volterra ~]$ /bin/dmesg | tail
ip_tables: (C) 2000-2002 Netfilter core team
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
pnp: Device 00:09 activated.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
lp0: using parport0 (interrupt-driven).
lp0: console ready
eth0: no IPv6 routers present

[petri@Volterra ~]$ mount /mnt
mount: can't find /mnt in /etc/fstab or /etc/mtab

[petri@Volterra ~]$ /bin/dmesg | tail
ip_tables: (C) 2000-2002 Netfilter core team
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
pnp: Device 00:09 activated.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
lp0: using parport0 (interrupt-driven).
lp0: console ready
eth0: no IPv6 routers present

Comment 8 Bill Nottingham 2005-03-25 13:20:32 EST
Sorry, perhaps I wasn't clear.

I want to know if there are any errors from:

"mount /dev/fd0 /mnt"

Comment 9 petri.poyhonen 2005-03-25 14:09:16 EST
There are kernel messages:

[petri@Volterra samba]$ sudo mount /dev/fd0 /mnt

This command does not exit (not within 30 secs).
Ctrl-C used to force the shell to be released.

[petri@Volterra samba]$ /bin/dmesg | tail
SELinux: initialized (dev smbfs, type smbfs), uses genfs_contexts
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
Buffer I/O error on device fd0, logical block 0
[petri@Volterra samba]$ 

Then finally after a delay of about 60 sec the system just spontaneously prints
the following text to the terminal

/dev/fd0: Invalid argument

Comment 10 Bill Nottingham 2005-03-25 14:18:07 EST
OK, this is either a problem with the floppy driver, or just a bad floppy disk.
 
Comment 11 petri.poyhonen 2005-03-26 03:44:24 EST
Confirmed.  Not a bug.
Closer hw review proves that power to the floppy drive was not well connected.

Thank you for your excellent responses on this thread !

Note You need to log in before you can comment on or make changes to this bug.