Bug 151664 - Jessie doesn't build: PATH_SEPARATOR not set
Summary: Jessie doesn't build: PATH_SEPARATOR not set
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: jessie   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-21 15:58 UTC by Anthony Green
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 19:07:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anthony Green 2005-03-21 15:58:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
I'm unable to build Jessie from SRPM.  The problem is that PATH_SEPARATOR isn't being set, so the compile lines look like:

CLASSPATH=/usr/share/java/gnu-crypto.jarclasses gcj -C -d classes etc etc etc

instead of

CLASSPATH=/usr/share/java/gnu-crypto.jar:classes gcj -C -d classes etc etc etc

The strange thing is that I get this same result even if I add the following to the spec file....

export PATH_SEPARATOR=':'



Version-Release number of selected component (if applicable):
jessie-1.0.0-3

How reproducible:
Always

Steps to Reproduce:
1.Try to rpmbuild jessie from the SRPM.
2.
3.
  

Additional info:

Comment 1 Thomas Fitzsimmons 2005-04-15 19:07:23 UTC
This works for me on my Rawhide system.  Closing.



Note You need to log in before you can comment on or make changes to this bug.