Bug 151668 - autofs-4.1.3-104 will not fall through wildcard in maps.
Summary: autofs-4.1.3-104 will not fall through wildcard in maps.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Regression
: 156037 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-21 16:29 UTC by Eric Paris
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version: RHBA-2005-178
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 22:05:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to allow fallthrough (394 bytes, patch)
2005-03-21 16:29 UTC, Eric Paris
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:177 normal SHIPPED_LIVE Normal: autofs bug fix update 2005-05-19 04:00:00 UTC
Red Hat Product Errata RHBA-2005:178 normal SHIPPED_LIVE autofs bug fix update 2005-06-09 04:00:00 UTC

Description Eric Paris 2005-03-21 16:29:50 UTC
Description of problem:  The autofs proposed for RHEL3 U5 will not fall through
a wildcard in an indirect map looking for a more specific entry.  Entries which
appear in autofs before the wildcard will be correctly used, but the wildcard
will match everything after it, which mean later entries will never get checked.


How reproducible:   Always


Steps to Reproduce:
1.  Set up local files like

auto.master:
/home      /etc/auto.home

auto.home
working   nfs.server:/export/working/directory
*         nfs.server:/export/catchall/&
broken    nfs.server:/export/working/directory

2.  cd to /home/broken
  
Actual results:  the /home/broken tries to mount nfs.server:/export/catchall/broken


Expected results:  the /home/broken should mount
nfs.server:/export/working/directory


Additional info:  notice that the entry before the wildcard does work. 
/home/working actually does mount nfs.server:/export/working/directory.

Comment 1 Eric Paris 2005-03-21 16:29:50 UTC
Created attachment 112182 [details]
Patch to allow fallthrough

Comment 3 Chris Feist 2005-03-23 18:01:11 UTC
Verified that the patch works and that's all that is needed.  The fix will be
built into the next autofs RHEL3 build.

Comment 8 Chris Feist 2005-03-31 16:01:42 UTC
Fix is in autofs-4.1.3-112.

Comment 9 Chris Feist 2005-04-26 21:34:53 UTC
*** Bug 156037 has been marked as a duplicate of this bug. ***

Comment 10 Dennis Gregorovic 2005-05-19 22:05:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-177.html



Note You need to log in before you can comment on or make changes to this bug.