Bug 151675 - QDIO direct mode does not work on z/VM 3.1 in RHEL 4
QDIO direct mode does not work on z/VM 3.1 in RHEL 4
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 12:40 EST by Chris Snook
Modified: 2008-10-06 16:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 16:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2005-03-21 12:40:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1 Red Hat/1.0.1-1.4.3

Description of problem:
When attempting to use a dedicated OSA card in QDIO direct mode on RHEL 4 with older versions of z/VM (3.1 does not work, 4.4 and 5.1 do work), the qeth interface doesn't work.  No packets are received remotely, and ifconfig never shows RX bytes incrementing.  The release notes do not specify a minimum required version of z/VM required to run RHEL 4 or to use QDIO in RHEL 4.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install z/VM 3.1 on an s390x
2. Configure z/VM to dedicate an OSA card to a linux guest
3. Configure the linux guest to use QDIO according to the release notes
  

Actual Results:  On z/VM 3.1, the qeth interface doesn't work.  On z/VM 4.4 and 5.1, it works.

Expected Results:  Either the interface should work with z/VM 3.1, or the documentation should list a minimum version of z/VM required to use this feature.

Additional info:

The following tell-tale messages appear in /var/log/messages (separated by many other normal messages)

kernel: cio: Was not able to determine available CHSCs, cc=2.
kernel: qdio : Not all CHSCs supported. Continuing.
kernel: qeth: Could not set up broadcast echo filtering on eth0: 0xffffe00d
Comment 2 Chris Snook 2008-10-06 16:54:21 EDT
This feature does not work with z/VM 3.1 because the feature is not present in z/VM.  This feature is present in all releases of z/VM currently supported by IBM.  Closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.