Bug 151693 - gimp man pages have non-standard names
gimp man pages have non-standard names
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 14:08 EST by George Geller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 08:49:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Geller 2005-03-21 14:08:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
It looks like the man pages intalled with gimp have somewhat unusual names:

$ rpm -ql gimp | grep /usr/share/man
/usr/share/man/man1/gimp-2.2.1.gz
/usr/share/man/man1/gimp-remote-2.2.1.gz
/usr/share/man/man1/gimptool-2.0.1.gz
/usr/share/man/man5/gimprc-2.2.5.gz

So you have to say:
$ man gimp-2.2

Instead of just:
$ man gimp



Version-Release number of selected component (if applicable):
gimp-2.2.4-0.fc3.3

How reproducible:
Always

Steps to Reproduce:
1. Install gimp.
2. Do:
$ man gimp # it doesn't work
3. Do:
$ man gimp-2.2 # it works
  

Additional info:

I fixed it on my system with a few commands like:

$ ln -s /usr/share/man/man1/gimp-2.2.1.gz /usr/share/man/man1/gimp.1.gz

I think this needs to be part of the rpm's post install script of the man pages need to be named according to the standard in the first place.
Comment 1 Nils Philippsen 2005-03-22 08:49:44 EST
Fixed in gimp-2.2.4-5.

Note You need to log in before you can comment on or make changes to this bug.