Bug 151704 - yum doesn't use standard command line parser?
yum doesn't use standard command line parser?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 14:50 EST by Need Real Name
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:58:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-21 14:50:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050313 Epiphany/1.5.8

Description of problem:
yum doesn't allow the generous (and intuitive) parsing of command line arguments which other programs allow.

For example, yum -y update --exclude="openoffice*" fails completely.
yum -y --exclude="openoffice*" update works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Seth Vidal 2005-03-22 13:58:58 EST
The problem is that for pkg names it's impossible to separate them out.

remember a package name could easily be

--exclude=*foo*

so yum can't know any different.
Comment 2 Need Real Name 2005-03-22 14:07:40 EST
Why is --exclude=*foo* a problem? It doesn't begin with a hyphen..
Comment 3 Seth Vidal 2005-03-22 14:10:59 EST
everything coming AFTER the command is considered an argument, not an option/flag

--option/-flag command arg arg arg

so if you have:
-y update --exclude=foo --exclude=bar

then yum will think:
update --exclude=foo --exclude=bar

and fail to find those items available for update, ie: it's looking for pkgs named:
 --exclude=foo and --exclude=bar

do see what I'm saying?
Comment 4 Need Real Name 2005-03-22 14:14:52 EST
Yes, and that's the bug. It's less flexible with command line arguments that
other programs.

Note You need to log in before you can comment on or make changes to this bug.