Bug 151737 - gnome-keyboard-properties failed when choosing any hungarian layouts
gnome-keyboard-properties failed when choosing any hungarian layouts
Status: CLOSED DUPLICATE of bug 149333
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: control-center (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 16:34 EST by tusi
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 02:12:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tusi 2005-03-21 16:34:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1 Red Hat/1.0.1-1.4.3

Description of problem:
When I choose any hungarian keybord layouts using gnome-keyboard-properties, I got the followin error messages:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60801000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

Here is the wanted includes:
>xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us", "", ""

>gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
 layouts = [us,hu_qwerty]
 model = pc105
 overrideSettings = false
 options = [grp grp:alts_toggle]
 update_handlers = []


I have checked the /etc/X11/xkb directory and I have found, that symbols.dir and the directory symbols contains the appropriate files:
>symols.dir
...
-dp----- -------- hu(default)
--p----- -------- hu(standard)
--p----- -------- hu(101_qwertz_comma)
--p----- -------- hu(101_qwertz_dot)
--p----- -------- hu(101_qwerty_comma)
--p----- -------- hu(101_qwerty_dot)
--p----- -------- hu(102_qwertz_comma)
--p----- -------- hu(102_qwertz_dot)
--p----- -------- hu(102_qwerty_comma)
--p----- -------- hu(102_qwerty_dot)
h-p----- a------- hu(def_uni)
h-p----- a------- hu(def_102)
h-p----- a------- hu(def_101)
h-p----- a------- hu(def_qwertz)
h-p----- a------- hu(def_qwerty)
h-p----- --k----- hu(def_comma)
h-p----- --k----- hu(def_dot)
h-p----- am------ hu(def_common)
--p----- -------- hu(Sundeadkeys)
--p----- -------- hu(sundeadkeys)
--p----- -------- hu(nodeadkeys)
-dp----- a------- hu_US(basic)
--p----- a------- hu_US(Sundeadkeys)
--p----- a------- hu_US(sundeadkeys)
--p----- a------- hu_US(nodeadkeys)
-dp----- -------- hu_qwerty(default)
...

>ls -l symbols
...
-r--r--r--  1 root root 13255 Dec  9 17:07 hu
-r--r--r--  1 root root  7804 Dec  9 17:07 hu_US
-r--r--r--  1 root root   202 Dec  9 17:07 hu_qwerty
...

but keymap.dir and the directory keymap do not contain any files for the hungarian keymaps.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start gnome-keyboard-properties
2. choose Layouts tab
3. choose Hungarian(qwerty) on right side
4. click add
  

Actual Results:  Error message window containing:

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60801000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb


Expected Results:  Hungarian keyboard layout to add.

Additional info:
Comment 1 Matthias Clasen 2005-04-22 02:12:25 EDT

*** This bug has been marked as a duplicate of 124235 ***
Comment 2 tusi 2005-04-22 02:46:19 EDT

*** This bug has been marked as a duplicate of 149333 ***

Note You need to log in before you can comment on or make changes to this bug.