Bug 151744 - Unable to read eclipse documentation in wellcome tab
Unable to read eclipse documentation in wellcome tab
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 17:25 EST by Jan-Petter Vainionpaa
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 16:06:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan-Petter Vainionpaa 2005-03-21 17:25:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
When I start eclipse from shell with command

eclipse -vm /usr/java/jdk1.5.0_02/jre/bin/java

but when I try to open some documentation from welcome screen in
overview (like workbench basics) after first click nothing happens, and
after second click I get message saying "An exception occured when
launching help. Refer to log for more details"

This feature is reported to work ok in i386 environment.

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M5.12

How reproducible:
Always

Steps to Reproduce:
1. Start eclipse from shell using either one of commands below (no matter which one you use). 

eclipse -vm /usr/java/jdk1.5.0_02/jre/bin/java

eclipse -clean -vm /usr/java/jdk1.5.0_02/jre/bin/java

2. On welcome tab, select overview
3. Select forexample link "workbench basics"
4. wait for a while, nothing happens (except logs are produced)
5. reclik the same link
  

Actual Results:  After second clik Help error dialog is presented with text:

"An exception occured when launching help. Refer to log for more details"

Expected Results:  It should be possible to read the documentation.

Additional info:

Slightly modified .log file from directory ~/workspace/.metadata/ is presented here:

> [jvainion@fsamd64 ~]$ cat workspace/.metadata/.log
> !SESSION 2005-03-20 21:27:21.46 ------------------------------------------------
> eclipse.buildId=I20050219-1500
> java.version=1.5.0_02
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
> Command-line arguments:  -os linux -ws gtk -arch x86_64 -data /home/jvainion/workspace
> 
> !ENTRY org.eclipse.ui 4 4 2005-03-20 21:27:21.46
> !MESSAGE Unhandled event loop exception
> 
> !ENTRY org.eclipse.ui 4 0 2005-03-20 21:27:21.47
> !MESSAGE org/eclipse/swt/internal/mozilla/nsEmbedString
> !STACK 0
> java.lang.NoClassDefFoundError: org/eclipse/swt/internal/mozilla/nsEmbedString
>         at org.eclipse.swt.browser.Browser.<init>(Browser.java:144)
>         at org.eclipse.help.ui.internal.browser.embedded.EmbeddedBrowserFactory.test(EmbeddedBrowserFactory.java:69)
>         at org.eclipse.help.ui.internal.browser.embedded.EmbeddedBrowserFactory.isAvailable(EmbeddedBrowserFactory.java:49)
>         at org.eclipse.help.internal.browser.BrowserManager.createBrowserDescriptors(BrowserManager.java:215)
> 
> ... snip ...
> 
>         at org.eclipse.core.launcher.Main.basicRun(Main.java:260)
>         at org.eclipse.core.launcher.Main.run(Main.java:887)
>         at org.eclipse.core.launcher.Main.main(Main.java:871)
> 
> !ENTRY org.eclipse.help.base 4 0 2005-03-20 21:27:59.552
> !MESSAGE An exception occurred while launching help.
> !STACK 0
> java.lang.NullPointerException
>         at org.eclipse.help.internal.browser.BrowserManager.createBrowserAdapter(BrowserManager.java:363)
>         at org.eclipse.help.internal.browser.BrowserManager.createBrowser(BrowserManager.java:338)
>         at org.eclipse.help.internal.base.BaseHelpSystem.getHelpBrowser(BaseHelpSystem.java:110)
> 
> ... snip ...
> 
>         at org.eclipse.core.launcher.Main.basicRun(Main.java:260)
>         at org.eclipse.core.launcher.Main.run(Main.java:887)
>         at org.eclipse.core.launcher.Main.main(Main.java:871)
>
Comment 1 Andrew Overholt 2005-04-08 14:15:19 EDT
Does this work without a proprietary JVM?
Comment 2 Billy Biggs 2005-04-21 19:18:21 EDT
Also note that this is on x86-64.  Eclipse upstream does not support the Browser
widget on x86-64, so it would be interesting to see if it's being built but
faking some stuff out (or if patches need to be applied to get it to work right)...

Otherwise, I would think that the help infrastructure should detect this case
and do something reasonable.  Does the same problem happen with the builds from
eclipse.org?
Comment 3 Ben Konrath 2006-10-04 16:06:53 EDT
This is working in the x86_64 packages in FC5 (3.1.2-1jpp_15fc). Closing bug as
won't fix because there are no plans for fix this in FC4.

Note You need to log in before you can comment on or make changes to this bug.