Bug 151749 - warnings on console when starting tomcat5 service
warnings on console when starting tomcat5 service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-21 18:07 EST by Anthony Green
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.30-8jpp_2fc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 05:02:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-03-21 18:07:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
I get the following:

# service tomcat5 start
Starting tomcat5: find: warning: you have specified the -mindepth option after a non-option argument -type, but options are not positional (-mindepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

find: warning: you have specified the -maxdepth option after a non-option argument -type, but options are not positional (-maxdepth affects tests specified before it as well as those specified after it).  Please specify options before other arguments.

Using CATALINA_BASE:     /usr/share/tomcat5
Using CATALINA_HOME:     /usr/share/tomcat5
Using CATALINA_TMPDIR:   /usr/share/tomcat5/temp
Using JAVA_HOME:         /usr/lib/jvm/java
                                                       [  OK  ]

Tomcat seems to run OK, but the warnings should be cleaned up maybe.

(and should we be using /tmp for CATALINA_TMPDIR?)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run "service tomcat5 start" on FC4test1
2.
3.
  

Additional info:
Comment 1 Fernando Nasser 2005-03-21 20:17:03 EST
I don't see this on RHEL so it may be something specific to Fedora.

Reassigning to Gary.
Comment 2 Gary A. McGee 2005-04-19 16:19:04 EDT
(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111
Firefox/1.0
> 
> Description of problem:
> I get the following:
> 
> # service tomcat5 start
> Starting tomcat5: find: warning: you have specified the -mindepth option after
a non-option argument -type, but options are not positional (-mindepth affects
tests specified before it as well as those specified after it).  Please specify
options before other arguments.
> 
> find: warning: you have specified the -maxdepth option after a non-option
argument -type, but options are not positional (-maxdepth affects tests
specified before it as well as those specified after it).  Please specify
options before other arguments.
> 
> Using CATALINA_BASE:     /usr/share/tomcat5
> Using CATALINA_HOME:     /usr/share/tomcat5
> Using CATALINA_TMPDIR:   /usr/share/tomcat5/temp
> Using JAVA_HOME:         /usr/lib/jvm/java
>                                                        [  OK  ]
> 
> Tomcat seems to run OK, but the warnings should be cleaned up maybe.
> 
> (and should we be using /tmp for CATALINA_TMPDIR?)
> 
> 
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1.run "service tomcat5 start" on FC4test1
> 2.
> 3.
>   
> 
> Additional info:

The problem as stated above occurs with FC4test2 also.

I have observed the same message during the boot process, and with "service
tomcat5 start".  When I run "/usr/bin/dtomcat5 start", I do not observe the
message.  Either way, tomcat5 does not start, yet the file /var/run/tomcat5.pid
exists.  When I run "ps -eaf", I do not observe a PID that matches the PID in
the tomcat5.pid file.
Comment 3 Anthony Green 2005-04-19 16:40:00 EDT
If tomcat5 isn't starting, then please open a new issue in bugzilla, including
all relevant logs (/var/log/tomcat5/*).  I think this must be unrelated to the
"find" message, since tomcat5 has always started for me.  Thanks!
Comment 4 Anthony Green 2005-04-21 17:46:50 EDT
The problem is with /usr/share/tomcat5/bin/
Comment 5 Anthony Green 2005-04-21 17:47:59 EDT
The problem is with /usr/share/tomcat5/bin/relink from the upstream JPackage.

The arguments to "find" need to be reordered so "-type d" is last.

Comment 6 Nicolas Mailhot 2005-07-18 11:38:04 EDT
Yep. Seems find behaviour changed in FC4 - this little script works as-is on
older releases.

Note You need to log in before you can comment on or make changes to this bug.