Bug 151767 - Pango halts on buggy fonts
Summary: Pango halts on buggy fonts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pango   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-22 05:01 UTC by Behdad Esfahbod
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-11 17:38:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 171170 None None None Never

Description Behdad Esfahbod 2005-03-22 05:01:59 UTC
Description of problem:
pango halts with 100% CPU usage if a font contains a lookup index out of range.

Version-Release number of selected component (if applicable):
pango-1.6.0-7


A patch is attached to external bug.

Comment 1 Matthias Clasen 2006-03-11 17:38:21 UTC
I will not fix this in fc3. The problem is fixed in fc5


Note You need to log in before you can comment on or make changes to this bug.