Bug 151772 - internal compiler error: Floating point exception
internal compiler error: Floating point exception
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 03:06 EST by drago01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 3.4.3-22.fc3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 05:32:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source (82.75 KB, text/plain)
2005-03-22 03:08 EST, drago01
no flags Details

  None (edit)
Description drago01 2005-03-22 03:06:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
While I was trying to compile my app (memory benchmark) with the -ggdb flag, gcc returned this:
make debug
gcc prog.c -ggdb -O3 -pipe -funroll-loops -fpeel-loops -funswitch-loops -fweb  -fsched2-use-superblocks -fsched2-use-traces -m3dnow -fvpt -msse -mmmx -ffast-math -malign-double -static -fforce-addr -fbranch-target-load-optimize2 -m32 -fprefetch-loop-arrays -fno-trapping-math -fomit-frame-pointer  -o bench
prog.c: In function `ram_bench':
prog.c:80: internal compiler error: Floating point exception
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccWY5bkj.out file, please attach this to your bugreport.
make: *** [debug] Error 1
So I decided to report it here ...
I will attach the /tmp/ccWY5bkj.out file after submiting this report.
It works fine without -ggdb.


Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Always

Steps to Reproduce:
1. try to compile this code with this flags
2. see the error message
3.
  

Actual Results:  internal compiler error, build aborted

Expected Results:  the compiler should build my app

Additional info:

Kernel : 2.6.10-1.770_FC3
gcc: gcc-3.4.2-6.fc3
gdb: gdb-6.1post-1.20040607.43
Comment 1 drago01 2005-03-22 03:08:28 EST
Created attachment 112209 [details]
Preprocessed source
Comment 2 Jakub Jelinek 2005-03-22 05:32:55 EST
Can't reproduce with gcc-3.4.3-22.fc3 (ATM in fc3 updates testing).
Comment 3 drago01 2005-03-22 06:15:14 EST
I installed gcc-3.4.3-22.fc3 from updates-testing via yum and it works, thx

Note You need to log in before you can comment on or make changes to this bug.