This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 151798 - PATCH: Fix bug in the new SWIG 1.3.24 support.
PATCH: Fix bug in the new SWIG 1.3.24 support.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 10:15 EST by Max Bowsher
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.1.3-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 11:26:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Max Bowsher 2005-03-22 10:15:31 EST
Additional development since bug 141343:

We have discovered a small bug in the Subversion SWIG 1.3.24 support.
Here is a patch.

This patch, and the one from bug 141343 will be included in Subversion 1.1.4,
which will hopefully be released very soon.


Patch:

Fix Python bindings bug that manifested only with SWIG 1.3.24
and threaded APR. Anything using a log_receiver callback would fail.

--- subversion/bindings/swig/python/libsvn_swig_py/swigutil_py.c (original)
+++ subversion/bindings/swig/python/libsvn_swig_py/swigutil_py.c Sun Mar 20
16:07:55 2005
@@ -1267,7 +1267,6 @@
 {
   PyObject *receiver = baton;
   PyObject *result;
-  swig_type_info *tinfo = SWIG_TypeQuery("svn_log_changed_path_t *");
   PyObject *chpaths;
   svn_error_t *err = SVN_NO_ERROR;

@@ -1278,6 +1277,7 @@

   if (changed_paths)
     {
+      swig_type_info *tinfo = SWIG_TypeQuery("svn_log_changed_path_t *");
       chpaths = svn_swig_py_convert_hash (changed_paths, tinfo);
     }
   else
Comment 1 Joe Orton 2005-03-22 11:26:22 EST
Thanks again!

Note You need to log in before you can comment on or make changes to this bug.