Bug 151800 - OOo completely fails to start
OOo completely fails to start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
: 151860 151996 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 10:22 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version: 1.9.87-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 08:37:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-03-22 10:22:18 EST
Description of problem:
All main components within OOo (draw, impress, writer, calc, math) fail to start
from either the gnome menu icon or from a command line.

Version-Release number of selected component (if applicable):
1.9.87-1

How reproducible:
Always

Steps to Reproduce:
1. Update from 1.9.85-1
2. Start from the command line or from a gnome menu
3.
  
Actual results:
From the command line, the error "no suitable windowing system found. exiting"
occurs.

Expected results:
OOo should fire up

Additional info:
I'm using rawhide with the latest xorg and a gnome desktop environment. Using
kernel 2.6.11-1.1185_FC4
Comment 1 Lars G 2005-03-22 11:22:48 EST
same here
Comment 2 Caolan McNamara 2005-03-23 03:44:57 EST
*** Bug 151860 has been marked as a duplicate of this bug. ***
Comment 3 Caolan McNamara 2005-03-23 04:19:53 EST
1.9.87-2 should unblock this
Comment 4 Caolan McNamara 2005-03-24 06:06:30 EST
*** Bug 151996 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2005-03-24 08:37:38 EST
works for me(tm) with 1.9.87-2
Comment 6 Demond James 2005-03-25 09:54:22 EST
Still no luck with openoffice.org-1:1.9.87-2

[lanos ~]$ oowriter
javaldx: Could not find a Java Runtime Environment! 
no suitable windowing system found, exiting.
[lanos ~]$ rpm -q openoffice.org-writer
openoffice.org-writer-1.9.87-2
Comment 7 Caolan McNamara 2005-03-29 06:18:52 EST
can you do
> rpm -q startup-notification
and
> rpm -q libgcj
and what's your desktop gnome or kde ?
Comment 8 Demond James 2005-03-29 08:59:37 EST
I'm running gnome

[lanos ~]$ rpm -q startup-notification
startup-notification-0.8-2
[lanos ~]$ rpm -q libgcj              
libgcj-4.0.0-0.37
Comment 9 Caolan McNamara 2005-03-29 09:08:15 EST
strange, I've got those and openoffice.org-core 1.9.87-2 and I'm not seeing a
"no suitable windowing system" error, or the "Could not find a JRE error", which
should be more of a warning than a fatal error.
Comment 10 Demond James 2005-03-29 09:18:40 EST
I did a fresh install with FC4 test1 x86_64 DVD iso and have been keeping the
system up to date with  Rawhide.  OO.o has been giving that error form day 1. 
Let my know if there is anything else that you want me to run/do.
Comment 11 Demond James 2005-03-29 09:21:24 EST
[lanos ~]$ yum list all libgcj
Setting up Repos
Reading repository metadata in from local files
Installed Packages
libgcj.x86_64                            4.0.0-0.37             installed

should the i386 version be available in the x86_64 tree?       
Comment 12 Brian Davids 2005-03-31 20:43:13 EST
(In reply to comment #10)
> I did a fresh install with FC4 test1 x86_64 DVD iso and have been keeping the
> system up to date with  Rawhide.  OO.o has been giving that error form day 1. 
> Let my know if there is anything else that you want me to run/do.

I had the "no suitable windowing system" problem on my x86_64 rawhide box until
I installed startup-notification.i386 just now.  The JRE error I got past by
installing the j2re.i586 package from the dag repository.
Comment 13 Demond James 2005-04-02 09:39:16 EST
Just installing startup-notification.i386 worked for me.  I still get the
javaldx warning but I think it was pointed out that that's no biggie.

Note You need to log in before you can comment on or make changes to this bug.