Bug 151831 - "Standard" PDF files that evince doesn't like
"Standard" PDF files that evince doesn't like
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 13:47 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 17:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evince backtrace (1.43 KB, application/octet-stream)
2005-04-11 05:35 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-03-22 13:47:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050313 Epiphany/1.5.8

Description of problem:
Thought it might be useful to have a list of PDFs included in the standard FC4 distro which evince doesn't get on well with.

I used:
 for i in $(locate .pdf|grep ".pdf$"|egrep -v '(^/home|^/m)');
waited until the file had finished loading, then closed each window.

PDF files under:
 /usr/share/festival/voices/
don't seem to be PDF files at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-03-22 14:12:24 EST
Should be:
 for i in $(locate .pdf|grep ".pdf$"|egrep -v '(^/home|^/m)'); do echo $i;
evince $i; done
Comment 2 shrek-m 2005-03-22 14:14:10 EST
sitenote: i am missing gpdf, ggv in fc4t1  :-(

evince-0.1.7-1.ppc
-->
$ evince /usr/share/evolution/2.2/help/quickref/C/quickref.pdf
i get an error "The Application "evince" has quit unexpectedly"

evince-0.1.9-1.ppc
--> it is ok, thanks.
Comment 3 Need Real Name 2005-03-22 14:16:20 EST
That file works for me - not using ppc though.

$ rpm -q evince
evince-0.1.9-1
Comment 4 Bryan W Clark 2005-03-28 10:30:27 EST
This breaks in CVS HEAD now (bt):

(gdb) bt
#0  0x008877e2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0078beab in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x0020c223 in libgnomeui_segv_handle (signum=11) at gnome-ui-init.c:741
#3  <signal handler called>
#4  0x08064c01 in Thumb (this=0x9d2c630, xrefA=0x148, obj=0xbfe2b2f0)
    at /opt/gnome2/include/poppler/Object.h:299
#5  0x0806353e in pdf_document_thumbnails_get_dimensions (
    document_thumbnails=0x9c958f0, page=328, size=100, width=0xbfe2b3a8,
    height=0xbfe2b3a4) at pdf-document.cc:1398
#6  0x0806dd2e in ev_document_thumbnails_get_dimensions (document=0x9c958f0,
    page=1, suggested_width=100, width=0xbfe2b3a8, height=0xbfe2b3a4)
    at ev-document-thumbnails.c:75
#7  0x08061a16 in ev_sidebar_thumbnails_set_document (
    sidebar_thumbnails=0x9c0d838, document=0x9c958f0)
    at ev-sidebar-thumbnails.c:243
#8  0x08060c15 in ev_sidebar_set_document (sidebar=0x9bfa3f8,
    document=0x9c958f0) at ev-sidebar.c:408
#9  0x0805dde8 in start_loading_document (ev_window=0x9bc0f00, document=Variable
"document" is not available.
)
    at ev-window.c:550
#10 0x0805dfa7 in ev_window_open (ev_window=0x9bc0f00,
    uri=0x9b99748
"file:///usr/share/evolution/2.2/help/quickref/C/quickref.pdf") at ev-window.c:749
#11 0x08061dd9 in main (argc=2, argv=0xbfe2b554) at main.c:59
Comment 5 Need Real Name 2005-04-08 17:18:41 EDT
WFM, although the paper orientation is wrong - it should be landscape.
I do get assertion failures though.

$ rpm -q evince
evince-0.2.0-1
[user@localhost ~]$  evince /usr/share/evolution/2.2/help/quickref/C/quickref.pdf

** (evince:5214): CRITICAL **: PopplerPage*
poppler_document_get_page(PopplerDocument*, int): assertion `0 <= index && index
< poppler_document_get_n_pages (document)' failed

** (evince:5214): CRITICAL **: void
pdf_document_thumbnails_get_dimensions(EvDocumentThumbnails*, gint, gint, gint*,
gint*): assertion `poppler_page != NULL' failed
Comment 6 Need Real Name 2005-04-10 06:18:01 EDT
The NY Times ad is crashing evince:
 http://www.mozilla.org/press/nytimes-firefox-final.pdf
Comment 7 Need Real Name 2005-04-11 05:35:11 EDT
Created attachment 112939 [details]
evince backtrace

Page 4 of the max-rpm doc crashes evince-0.2.0-1 too:
 http://www.redhat.com/docs/books/max-rpm/max-rpm.pdf

backtrace attached.
Comment 8 Need Real Name 2005-04-14 04:59:47 EDT
evince-thumbnailer doesn't like:
 http://www.peoples-press.com/today.pdf
But evince can display it fine.
Comment 9 Need Real Name 2005-04-26 03:17:24 EDT
(In reply to comment #6)
> The NY Times ad is crashing evince:
>  http://www.mozilla.org/press/nytimes-firefox-final.pdf
> 

evince isn't crashing on this now - but it also isn't displaying the logo in the
advert (http://www.mozilla.org/images/nyt_ad_large_2004.png)
Comment 10 Need Real Name 2005-05-10 05:48:52 EDT
evince-0.2.1-1:
 Page 4 of http://www.redhat.com/docs/books/max-rpm/max-rpm.pdf still causes crash.
 Firefox advert still looks different.
Comment 11 Marco Pesenti Gritti 2005-05-31 06:42:58 EDT
Can we have an update on this for 0.3.1?
This is about pdf included in the distribution, please don't put any random pdf
that doesnt work in here... file separate bugs.
Comment 12 Need Real Name 2005-06-01 12:55:21 EDT
During the update to 0.3.1 I get:
 I/O error : Attempt to load network entity
http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd

Ignoring that.
Running evince on anything gives:
 
/usr/share/doc/libtheora-1.0alpha4/Theora_I_spec.pdf
evince: symbol lookup error: /usr/lib/libpoppler-glib.so.0: undefined symbol:
_ZTI7LinkURI

Missing dependency? I'll do a full update and check again.
Comment 13 Marco Pesenti Gritti 2005-06-01 13:06:07 EDT
You should update poppler. Though evince should depend on the correct poppler
version. If you could open a bug about that it would be useful...
Comment 14 Need Real Name 2005-06-01 13:20:41 EDT
Submitted (bug 159322).

All distro pdfs which I have now work - with one group of exceptions: the
"festivals pdfs that aren't pdfs".

Out of distro, the max rpms book now works too.
The firefox one doesn't look like it should yet.

Thanks!
Comment 15 Marco Pesenti Gritti 2005-06-06 06:07:04 EDT
Closing, I guess the festival .pdf arent pdf at all since they are under the
voices/ directory.
Comment 16 Need Real Name 2005-10-14 08:15:22 EDT
This document renders completely wrong:
 http://www.speedtouch.com/pdf%5Cdatasheet546.pdf

as does
 http://www.mozilla.org/press/nytimes-firefox-final.pdf

Both appear to have the same problem - garbled text.
Comment 17 Need Real Name 2005-10-25 11:04:37 EDT
and, ironically, http://www.linux-magazine.com/issue/61/Evince_PDF_Viewer.pdf
Comment 18 Need Real Name 2005-11-13 08:23:34 EST
http://www.londontown.com/url/Christmas2005.pdf is broken by evince too
Comment 19 Andrew Overholt 2005-11-16 17:09:11 EST
Here's another:

http://www.torontorealestate.ca/pdffiles/eBBuy3s-Find.pdf
Comment 20 Need Real Name 2005-12-16 02:28:29 EST
Where can I get the FC4 evince that worked please?
Comment 21 Kristian Høgsberg 2006-09-22 17:39:20 EDT
Except for the PDF in comment #18 all PDFs in this bug seems to work.  I've
logged the Christmas PDF upstream, so I'm closing this bug.  In general, please
file a bug per broken PDF you come across and do look for an existing, similar
sounding bug before opening a new one.

Note You need to log in before you can comment on or make changes to this bug.