Bug 151861 - Internal USB card reader not functioning
Internal USB card reader not functioning
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 151848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-22 18:22 EST by Paul F. Johnson
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 18:31:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg file (20.42 KB, text/plain)
2005-03-22 18:22 EST, Paul F. Johnson
no flags Details
/proc/bus/usb/devices listing (2.19 KB, text/plain)
2005-03-23 03:57 EST, Paul F. Johnson
no flags Details
dmesg file after latest updates (20.39 KB, text/plain)
2005-03-25 15:51 EST, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2005-03-22 18:22:42 EST
Description of problem:
I have an internal USB 7 in 1 card reader. Under previous kernels (such as
2.6.10-1.1063 and 1.1105), I have managed to get this working by adding into
/etc/modprobe.conf

options scsi_mod_luns=8

and then mkinitrd to the kernel, reboot and all worked.

The current kernels (from around 2.6.11) seem to have stopped this device working.

Version-Release number of selected component (if applicable):
2.6.11-1.1185_FC4

How reproducible:
Always

Steps to Reproduce:
1. Insert an SD card into the reader
2.
3.
  
Actual results:
Nothing

Expected results:
The card should be read

Additional info:
Using hal-0.5.0-cvs200505018-1 & hotplug-2004_09_23-3
Comment 1 Paul F. Johnson 2005-03-22 18:22:42 EST
Created attachment 112235 [details]
dmesg file
Comment 2 Paul F. Johnson 2005-03-22 18:26:25 EST
*** Bug 151848 has been marked as a duplicate of this bug. ***
Comment 3 Pete Zaitcev 2005-03-22 21:35:40 EST
Paul, I need /proc/bus/usb/devices, too, if you please.
Comment 4 Paul F. Johnson 2005-03-23 03:57:04 EST
Created attachment 112248 [details]
/proc/bus/usb/devices listing

As requested
Comment 5 Paul F. Johnson 2005-03-25 15:50:40 EST
Update to latest mkinitrd (sorry, can't remember the rpm name!) makes no
difference. USB reader recognised but won't load cards.
Comment 6 Paul F. Johnson 2005-03-25 15:51:49 EST
Created attachment 112353 [details]
dmesg file after latest updates
Comment 7 Paul F. Johnson 2005-04-03 07:05:22 EDT
Update to current kernel (1225_FC4) does not resolve this problem
Comment 8 Paul F. Johnson 2005-04-16 20:34:25 EDT
kernel 1238_FC4 allowed the card in the reader to be mounted once and then would
fail to mount again. 1240_FC4 won't allow the reader to get that far. This is wierd!
Comment 9 Dave Jones 2005-06-27 19:16:20 EDT
Mass update of -test bugs to update version to fc4.
(Please retest on final release, and report results if you have not already done
so).

Thanks.
Comment 10 Paul F. Johnson 2005-06-28 03:00:13 EDT
What information is needed?
Comment 11 Dave Jones 2005-07-15 17:06:48 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 12 Dave Jones 2005-09-30 02:07:25 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 13 Paul F. Johnson 2005-09-30 18:31:44 EDT
Retested. No go. However, after unplugging it, switch off, plug back in - it
works fine. Not sure what that means though. Possibly kudzu picking it up again?
Anyway, it's working now, so I'll close the bug.

Note You need to log in before you can comment on or make changes to this bug.