Bug 151879 - Java Plug-in (Blackdown) crashes Fedora Core 4 on AMD64
Java Plug-in (Blackdown) crashes Fedora Core 4 on AMD64
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
www.yahoo.com/games/download/tx.html
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 00:51 EST by Cynthia Jeness
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-30 11:34:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cynthia Jeness 2005-03-23 00:51:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
Installed Fedora Core4 test1.  Did NOT select java packages.   Separately downloaded JDK 1.4.2 and JRE 1.5.0.   Manually linked Java plugin to the plugins directory under /usr/lib64/firefox1.0.1/plugins.   Java is enabled in Firefox.  We have tried the plugin under Java 1.4 and also under 1.5.  Neither of these plugins is recognized by Firefox.   Other aspects of the both JDK 1.4/1.5 appear to work correctly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Steps are described in the Description field.
1.
2.
3.
  

Actual Results:  Web site claims that plug-in is not installed.

Expected Results:  Java applet would display.

Additional info:
Comment 1 Warren Togami 2005-03-23 00:53:03 EST
Are you sure the java you downloaded is native x86_64 binaries?
Comment 2 Cynthia Jeness 2005-03-23 11:09:41 EST
OK.  You are correct that I did not have the x86_64 binaries.   So I went back
to sun and found the AMD64 for J2SE 5.0 and installed it.   This did not have a
plugins directory.   Then, I went to Blackdown and downloaded the 1.4 J2SE for
AMD 64.   This did have a plugin directory and I made the appropriate link.  
When I went to the Yahoo games page, now the Java plugin was recognized, but
Firefox crashed.   Finally, I did go back and install the Java development
package from the Fedora CDs.   This did not seem to provide a plugin either.

So, in short, what is the correct source for the AMD64 plugin and how do I make
it work.

Thanks
Comment 3 Warren Togami 2005-03-23 13:05:25 EST
OK, this isn't a Fedora bug per-se, but maybe Andrew would know the answer.

Andrew, do you know if there exists a x86_64 java plugin that works with FC4?
Comment 4 Andrew Overholt 2005-03-23 13:55:55 EST
Tom would know best.
Comment 5 Thomas Fitzsimmons 2005-03-23 14:12:59 EST
So the plugin shows up when you browse to "about:plugins"?  Are you linking the
plugin *directory* somewhere or an individual plugin?  What is the "appropriate
link" you created?  Crashes like these are usually caused by ABI differences in
the C++ compilers used to build firefox and the plugin.  IBM differentiates
plugins compiled with different ABIs by different suffixes on libjavaplugin. 
Are multiple libjavaplugin files shipped with the Blackdown JRE?
Comment 6 Cynthia Jeness 2005-03-23 19:18:50 EST
In firefox, I cannot find an "About: Plugins" under Help or any other menu.  I
know that the plug-in is recognized because when I go to the yahoo site which
requires Java, it brings up the Java coffee cup.

The Blackdown JVM has only one plug-in supplied for their AMD64 version.   I am
linking this individual plug-in to the same name in the plugins directory under
lib64/firefox-1.01.
Comment 7 Cynthia Jeness 2005-03-23 19:33:34 EST
In the last sentence, I should have said "/usr/lib64/firefox-1.01/plugins.  This
is the same directory where the null plugin is located.
Comment 8 Warren Togami 2005-03-24 02:15:24 EST
You just put "about:plugins" into the URL bar and it shows you plugins that the
browser is using.
Comment 9 Cynthia Jeness 2005-03-24 17:54:12 EST
OK.  I put "about:plugins" in the URL bar and it showed that the Blackdown
plugin was being used and provided a long list of java services that were handled.  
Comment 10 Warren Togami 2005-04-29 01:49:10 EDT
Is this still an issue with the latest FC4 versions?
What if you remove the JVM probing stuff from /usr/bin/firefox?
Comment 11 Cynthia Jeness 2005-04-30 11:03:02 EDT
No.  This is no longer a problem.
Comment 12 Christopher Aillon 2005-04-30 11:34:10 EDT
Cool.  Resolving worksforme.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.