Bug 151888 - menu system: ".directory" files in <LegacyDir>s not used
menu system: ".directory" files in <LegacyDir>s not used
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
RHEL4U3NAK
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 03:54 EST by Mark McLoughlin
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-09 18:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the bug (898 bytes, patch)
2005-03-23 03:54 EST, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Mark McLoughlin 2005-03-23 03:54:51 EST
<LegacyDir> is used to create menus from an on-disk dierarchy of directories and
.desktop files.

It would look something like this:

  Windows_Applications
  Windows_Applications/.directory
  Windows_Applications/WinZip.desktop
  Windows_Applications/Programs
  Windows_Applications/Programs/.directory
  Windows_Applications/Programs/WinZip
  Windows_Applications/Programs/WinZip/.directory
  Windows_Applications/Programs/WinZip/WinZip_8.1_SR-1_.desktop
  Windows_Applications/Programs/WinZip/ReadMe.txt.desktop
  Windows_Applications/Programs/WinZip/Uninstall_WinZip.desktop
  Windows_Applications/Programs/WinZip/What's_New.desktop

The problem is that our menu system doesn't pick up the ".directory" files in
each of these directories which describe the icon to display and the localized
name for the directory.

So you get a silly default icon and unlocalized menu names.
Comment 1 Mark McLoughlin 2005-03-23 03:54:51 EST
Created attachment 112246 [details]
patch to fix the bug
Comment 3 Mark McLoughlin 2005-03-23 06:05:45 EST
Fix is in gnome-vfs-2.8.2-8.3, errata is RHBA-2005:338
Comment 13 RHEL Product and Program Management 2006-10-09 18:10:38 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 14 RHEL Product and Program Management 2006-10-09 18:18:10 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.