Bug 151977 - Advanced Preferences options dialog not shown
Advanced Preferences options dialog not shown
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
: 152009 152015 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 18:27 EST by Frank Büttner
Modified: 2007-11-30 17:11 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 15:36:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here is the output when selecting the advanced option (55.97 KB, image/png)
2005-03-23 18:29 EST, Frank Büttner
no flags Details
Updated patch file... should do the job.. (5.16 KB, patch)
2005-03-24 10:25 EST, Ventsislav Genchev
no flags Details | Diff

  None (edit)
Description Frank Büttner 2005-03-23 18:27:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
The advanced option dialog is not shown. See file for the problem.

Version-Release number of selected component (if applicable):
thunderbird-1.0.2-1.3.1

How reproducible:
Always

Steps to Reproduce:
1. open option for tb
2. select advanced
  

Actual Results:  missing option page

Expected Results:  the advanced option page.

Additional info:
Comment 1 Frank Büttner 2005-03-23 18:29:16 EST
Created attachment 112282 [details]
Here is the output when selecting the advanced option
Comment 2 Ian Pilcher 2005-03-23 18:52:27 EST
BTW, the error message shown is:

XML Parsing Error: not well-formed
Location: chrome://messenger/content/pref-advanced.xul
Line Number 208, Column 5:

----^
Comment 3 Nathan Aaron 2005-03-23 19:28:34 EST
I am seeing the exact same scenario.

Nathan
Comment 4 Eric Tanguy 2005-03-24 02:41:34 EST
I Have the same problem
Eric
Comment 5 Sebastien BLAISOT 2005-03-24 04:24:40 EST
same for me
Comment 6 Lars E. Pettersson 2005-03-24 05:23:50 EST
Ditto!

Tried both my regular account, and a new one, same result in both cases so no
old data laying around creating problems.

Lars
Comment 7 drago01 2005-03-24 06:46:15 EST
*** Bug 152009 has been marked as a duplicate of this bug. ***
Comment 8 drago01 2005-03-24 07:16:50 EST
rebuild it hasn't fixed the bug....
Comment 9 Matthew Miller 2005-03-24 09:26:38 EST
*** Bug 152015 has been marked as a duplicate of this bug. ***
Comment 10 Matthew Miller 2005-03-24 09:30:44 EST
(Correcting spelling in summary to reduce future dups)
Comment 11 Frank Büttner 2005-03-24 09:45:34 EST
Sorry, for the little mistake.:(
Comment 12 Ventsislav Genchev 2005-03-24 10:16:53 EST
The problem lies in
/usr/src/redhat/BUILD/mozilla/mail/components/prefwindow/content/pref-advanced.xul

cuz of inproper patching of this file... 

the nasty patch is called thunderbird-0.8-software-update.patch
and here is what it does.. 

---------------------------- cut here ----------------------

--- mozilla/mail/components/prefwindow/content/pref-advanced.xul.foo   
2004-10-18 20:22:51.000000000 -0400
+++ mozilla/mail/components/prefwindow/content/pref-advanced.xul       
2004-10-18 20:22:57.000000000 -0400
@@ -237,6 +237,7 @@
       </radiogroup>
     </expander>

+<!--
     <expander id="softwareupdate" label="&softwareupdate.label;"
               persist="open" clearhidden="true" align="left">
       <label>&softwareupdateinfo.label;</label>
@@ -252,6 +253,7 @@
                 oncommand="checkForUpdates();"/>
       </vbox>
     </expander>
+-->

   </vbox>
 </page>

---------------------- cut here ----------------------------




The result:


--------------------- cut here ------------------------

The result... 


--------------------- cut here ------------------------

<!--
    <expander id="softwareupdate" label="&softwareupdate.label;"
              persist="open" clearhidden="true" align="left">
      <label>&softwareupdateinfo.label;</label>
      <vbox class="indent" align="left">
<!--
        <checkbox id="enableSmartUpdate"
                  label="&enableSmartUpdate.label;"
accesskey="&enableSmartUpdate.accesskey;"
                  prefstring="app.update.autoUpdateEnabled"/>
        <checkbox id="enableExtensionUpdate"
                  label="&enableExtensionUpdate.label;"
accesskey="&enableExtensionUpdate.accesskey;"
                  prefstring="extensions.update.autoUpdateEnabled"/>
        <separator class="thin"/>
-->
        <button label="&checkNow.label;" accesskey="&checkNow.accesskey;"
                oncommand="checkForUpdates();"/>
      </vbox>
    </expander>
-->

---------------------- cut here ---------------------------


See the inproper comments??? Right.. 

so i suggest replacing those patch lines with the following example:


-------------------- cut here ---------------------------

--- pref-advanced.xul.orig      2004-11-18 05:43:13.000000000 +0200
+++ pref-advanced.xul   2005-03-24 17:13:45.320208128 +0200
@@ -237,11 +237,12 @@
       </radiogroup>
     </expander>

+<!--
     <expander id="softwareupdate" label="&softwareupdate.label;"
               persist="open" clearhidden="true" align="left">
       <label>&softwareupdateinfo.label;</label>
       <vbox class="indent" align="left">
-<!--
+
         <checkbox id="enableSmartUpdate"
                   label="&enableSmartUpdate.label;"
accesskey="&enableSmartUpdate.accesskey;"
                   prefstring="app.update.autoUpdateEnabled"/>
@@ -249,11 +250,12 @@
                   label="&enableExtensionUpdate.label;"
accesskey="&enableExtensionUpdate.accesskey;"
                   prefstring="extensions.update.autoUpdateEnabled"/>
         <separator class="thin"/>
--->
+
         <button label="&checkNow.label;" accesskey="&checkNow.accesskey;"
                 oncommand="checkForUpdates();"/>
       </vbox>
     </expander>
+-->

   </vbox>
 </page>

--------------------------- cut here ---------------------------



PS: sorry for the long post... i hope it helpped.. 
Comment 13 Ventsislav Genchev 2005-03-24 10:25:07 EST
Created attachment 112292 [details]
Updated patch file... should do the job.. 

I've added the new patch lines to this file and removed the old one.... must be
tested thou...
Comment 14 Aleksey Nogin 2005-03-24 12:48:40 EST
This was first reported (against 1.0RC3 in RawHide) as bug 141899 - it was
marked as fixed, but now it is back.
Comment 15 Ian Pilcher 2005-03-24 15:30:56 EST
Working in 1.0.2-1.3.2
Comment 16 Christopher Aillon 2005-03-24 15:36:40 EST
Basically, just forgot to merge the old patch in rawhide back to fc3. 
Resolved->ISUCK

Note You need to log in before you can comment on or make changes to this bug.