Bug 151996 - OO.org: no suitable windowing system found, exiting.
OO.org: no suitable windowing system found, exiting.
Status: CLOSED DUPLICATE of bug 151800
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-23 22:28 EST by Vijay Avarachen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 06:06:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Avarachen 2005-03-23 22:28:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.1 Fedora/1.0.1-6

Description of problem:
I just upgraded openoffice using yum from 1.9.84-1 -> 1.9.87-1.  Attempted to run writer and no go.  So I opened a shell and typed:

bash-3.00$ openoffice.org-1.9
no suitable windowing system found, exiting.

I deleted my old .openoffice.org folders:
bash-3.00$ rm -rf .openoffice.org
.openoffice.org1.9.84/ .openoffice.org2.0/
bash-3.00$ rm -rf .openoffice.org*

bash-3.00$ openoffice.org-1.9 -writer
no suitable windowing system found, exiting.

I started a new session (Xsession) and still no juice :-(

I am running gnome w/ metacity.  I have done no special modifications at all.

bash-3.00$ rpm -qa | grep metacity
metacity-2.9.21-2



Version-Release number of selected component (if applicable):
openoffice.org-core-1.9.87-1

How reproducible:
Always

Steps to Reproduce:
1. Open terminal
2. Type openoffice.org-1.9 -writer
3. Error: no suitable windowing system found, exiting.
  

Actual Results:  no suitable windowing system found, exiting.

Expected Results:  I expect OpenOffice to start up with writer.

Additional info:

Here is output of env:
bash-3.00$ env
SSH_AGENT_PID=5199
HOSTNAME=localhost.localdomain
DESKTOP_STARTUP_ID=
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
GTK_RC_FILES=/etc/gtk/gtkrc:/home/vijay/.gtkrc-1.2-gnome2
WINDOWID=44040292
QTDIR=/usr/lib/qt-3.3
USER=vijay
LS_COLORS=
GNOME_KEYRING_SOCKET=/tmp/keyring-TzbDXz/socket
SSH_AUTH_SOCK=/tmp/ssh-CvcDqJ5162/agent.5162
KDEDIR=/usr
SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/5162
USERNAME=vijay
PATH=/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin
DESKTOP_SESSION=gnome
MAIL=/var/spool/mail/vijay
GDM_XSERVER_LOCATION=local
PWD=/home/vijay
INPUTRC=/etc/inputrc
GDMSESSION=gnome
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SHLVL=2
HOME=/home/vijay
GNOME_DESKTOP_SESSION_ID=Default
LOGNAME=vijay
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-oJBedQwJdh,guid=572a424254afdc40f9a17f78746f2200
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=:0.0
G_BROKEN_FILENAMES=1
COLORTERM=gnome-terminal
XAUTHORITY=/home/vijay/.Xauthority
_=/usr/bin/env
OLDPWD=/var/log
Comment 1 Vijay Avarachen 2005-03-23 23:40:17 EST
Ok! I did some searching on the net and the only info I found is a mention of
this bug on the kde website. (http://dot.kde.org/1101482981).
According to that post:
"You need libstartup-notification installed, otherwise it fails to run with "no
suitable windowing system found, exiting."

So I check to see if I have startup-notification installed:
[root@localhost ~]# rpm -qa | grep startup
startup-notification-0.8-2

[root@localhost ~]# ldconfig -v | grep startup
        libstartup-notification-1.so.0 -> libstartup-notification-1.so.0.0.0

So looks like it is installed!  I also did some searching on openoffice.org
website but didn't really get any results.

I should mention that when I had originally installed FC4t1 on this box, I
installed KDE and Gnome.  After upgrading all the packages today I decided to
uninstall KDE.  So I did: yum remove kde-base.  It prompted me to remove the
dependencies (all KDE packages) and I gave it the green light.  

When I initially installed this box, OO.org was working.
Comment 2 Steven Lawrance 2005-03-24 04:43:01 EST
I'm experiencing the same issue, though my box was upgraded from FC3 via yum. I
also have startup-notification installed. I'll try to install KDE and see if
that fixes it..
Comment 3 Caolan McNamara 2005-03-24 06:06:17 EST

*** This bug has been marked as a duplicate of 151800 ***
Comment 4 Steven Lawrance 2005-03-24 13:15:47 EST
The latest version "Works for Me" [tm] :-)! Thanks!

Note You need to log in before you can comment on or make changes to this bug.