Bug 152020 - rpm sees #'s in %changelog as comment
rpm sees #'s in %changelog as comment
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 08:55 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 16:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-24 08:55:29 EST
Description of problem:
From vim-6.3.067-1's %changelog (out of the spec file):

--- snipp ---
* Wed Mar 23 2005 Karsten Hopp <karsten@redhat.de> 6.3.067-1
- Newly created files got execute permission (caused by patch 66)
  #151667
--- snapp ---

From the rpm package itself:

--- snipp ---
> rpm -qp --changelog vim-6.3.067-1.src.rpm | head -n 3
* Mi Mär 23 2005 Karsten Hopp <karsten@redhat.de> 6.3.067-1
- Newly created files got execute permission (caused by patch 66)

>
--- snapp ---

RPM should read #'s in changelog with prefixed spaces as normal character not
as comment.

Ah, and the problem is not bash/shell related, querying the package via rpm-
python gives the same result.

Version-Release number of selected component (if applicable):
rpm-4.4.1-8
vim-6.3.067-1

How reproducible:
Everytime, see above

Actual results:
rpm sees #'s in %changelog as comment.

Expected results:
rpm shouldn't see with spaces prefixed #'s in %changelog as comment.
Comment 1 Jeff Johnson 2005-03-24 13:28:35 EST
Lines in *.spec starting with '#' are comments, always been that way.

Your expectations add complexity for almost no gain.
Comment 2 Robert Scheck 2005-03-24 13:31:28 EST
I simply want to have a difference in behaviour in the %changelog (it's enough 
if only there) section between:

# foo

and

 # foo

because last of it, could be the same as my original report.

Where's the problem?
Comment 3 Robert Scheck 2005-10-12 16:14:22 EDT
Closing this bugreport after talking with Jeff about it in IRC...

Note You need to log in before you can comment on or make changes to this bug.