Bug 152028 - ls -l output badly aligned
ls -l output badly aligned
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: coreutils (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://lists.gnu.org/archive/html/bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 10:25 EST by Rob
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 10:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob 2005-03-24 10:25:42 EST
Description of problem:
There is a bug with the "ls -l" command and alignment of the timestamp and 
filename output. The ls command will currently show the entire owner and group 
names, which if they are long will distort the output horribly. I asked on the 
coreutils buglist about this, and they replied this was fixed as of coreutils-
5.1.0. Reference: 
http://lists.gnu.org/archive/html/bug-coreutils/2005-03/msg00145.html 



Version-Release number of selected component (if applicable):
coreutils-4.5.3-26


How reproducible:
Every Time

Steps to Reproduce:
1. ls -l
  
Actual results:
total 40 
drwxr-x--x    5 cbipropertyinspections cbipropertyinspectionsgrp     4096 Mar 
23 12:30 ./ 
drwxr-x--x   28 root     root         4096 Mar 23 12:28 ../ 
-rw-r--r--    1 cbipropertyinspections cbipropertyinspectionsgrp       24 Mar 
23 12:28 .bash_logout 
-rw-r--r--    1 cbipropertyinspections cbipropertyinspectionsgrp      191 Mar 
23 12:28 .bash_profile 
-rw-r--r--    1 cbipropertyinspections cbipropertyinspectionsgrp      124 Mar 
23 12:28 .bashrc 
drwxr-xr-x    2 root     root         4096 Mar 23 12:29 .wusage7/ 
lrwxrwxrwx    1 root     root           43 Mar 23 12:28 access-log -
> /www/logs/cbipropertyinspections-access-log 
-rw-r--r--    1 cbipropertyinspections users        1845 Mar 23 12:30 count.cfg 
lrwxrwxrwx    1 root     root           42 Mar 23 12:28 error-log -
> /www/logs/cbipropertyinspections-error-log 
drwxr-xr-x    2 cbipropertyinspections cbipropertyinspectionsgrp     4096 Mar 
23 12:28 infobots/ 
-rw-r--r--    1 cbipropertyinspections cbipropertyinspectionsgrp       71 Mar 
23 12:29 mailredirect 
drwxr-s--x    6 cbipropertyinspections cbipropertyinspectionsgrp     4096 Mar 
23 12:47 www/ 

Expected results:
total 40
drwxr-x--x   5 cbipropertyinspections cbipropertyinspectionsgrp 4096 Mar 23 
12:30 ./
drwxr-x--x  29 root                   root                      4096 Mar 24 
09:46 ../
-rw-r--r--   1 cbipropertyinspections cbipropertyinspectionsgrp   24 Mar 23 
12:28 .bash_logout
-rw-r--r--   1 cbipropertyinspections cbipropertyinspectionsgrp  191 Mar 23 
12:28 .bash_profile
-rw-r--r--   1 cbipropertyinspections cbipropertyinspectionsgrp  124 Mar 23 
12:28 .bashrc
drwxr-xr-x   8 root                   root                      4096 Mar 24 
06:15 .wusage7/
lrwxrwxrwx   1 root                   root                        43 Mar 23 
12:28 access-log -> /www/logs/cbipropertyinspections-access-log
-rw-r--r--   1 cbipropertyinspections users                     1845 Mar 23 
12:30 count.cfg
lrwxrwxrwx   1 root                   root                        42 Mar 23 
12:28 error-log -> /www/logs/cbipropertyinspections-error-log
drwxr-xr-x   2 cbipropertyinspections cbipropertyinspectionsgrp 4096 Mar 23 
12:28 infobots/
-rw-r--r--   1 cbipropertyinspections cbipropertyinspectionsgrp   71 Mar 23 
12:29 mailredirect
drwxr-s--x   6 cbipropertyinspections cbipropertyinspectionsgrp 4096 Mar 23 
12:47 www/
Comment 1 Tim Waugh 2005-03-24 10:43:31 EST
Is the problem that you find it hard to read, or that you have tools that rely
on a particular format, or a different reason?
Comment 2 Rob 2005-03-24 10:50:36 EST
Both actually. With a large directory of files with different length 
ownerships, the output is unreadable. We also use some scripts that depend on 
certain alignment which makes it hard to predict.
Comment 3 Tim Waugh 2005-04-07 10:05:16 EDT
I think this might be too risky a change at this point in the RHEL3 cycle. 
Although this format has changed since GA, incorporating the 5.2.1-style format
would still be a different format than the one shipped in GA, so if anything it
might make things worse.

I'm going to close this as CURRENTRELEASE, meaning that Red Hat Enterprise Linux
4 addresses this issue.

Note You need to log in before you can comment on or make changes to this bug.