Bug 152049 - Please package javadocs for eclipse-jdt and eclipse-platform
Please package javadocs for eclipse-jdt and eclipse-platform
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 11:47 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 12:55:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-03-24 11:47:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
If I go into Help and choose "JDT Plugin Developer Guide" and then choose "Reference", then "API Reference", the package names appear, but when I click on them, it says "The topic that you have requested is not available. The link may be wrong, or you may not have the corresponding product feature installed. This online help only includes documentation for features that are installed."

Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M5.12

How reproducible:
Always

Steps to Reproduce:
See above

Actual Results:  See above

Expected Results:  Should have displayed javadocs.

Additional info:
Comment 1 Ben Konrath 2005-03-29 15:01:17 EST
This is a bug not an enhancement request, changing severity.
Comment 2 Ben Konrath 2005-04-20 19:17:57 EDT
I can't reproduce this problem with the latest packages from rawhide:

Eclipse 3.1.0_fc-0.M6.7
GCC 4.0.0-0.42

Can you check to see if this problem is fixed for you too? Please close the bug
if  the problem is in fact gone. Thanks.
Comment 3 Ben Konrath 2005-04-20 19:25:05 EDT
Please ignore the above comment, I inadverting tested this with an upstream
release. Sorry for the spam.
Comment 4 Andrew Overholt 2005-04-21 16:10:47 EDT
We're getting errors while trying to build the javadocs.  The ant calls are a
mess of redirections, but after removing the -splitIndex option (which gjdoc
apparently doesn't have), we get this:

Running doclet...
Fetching package list for external documentation set.
java.lang.NullPointerException
   at java.io.InputStreamReader.read(char[], int, int) (/usr/lib/libgcj.so.6.0.0)
   at java.io.BufferedReader.fill() (/usr/lib/libgcj.so.6.0.0)
   at java.io.BufferedReader.readLine() (/usr/lib/libgcj.so.6.0.0)
   at
gnu.classpath.tools.doclets.htmldoclet.ExternalDocSet.readPackages(java.io.InputStream)
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at gnu.classpath.tools.doclets.htmldoclet.ExternalDocSet.load(java.io.File)
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at gnu.classpath.tools.doclets.htmldoclet.HtmlDoclet.run()
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at
gnu.classpath.tools.doclets.AbstractDoclet.startInstance(com.sun.javadoc.RootDoc)
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at gnu.classpath.tools.doclets.AbstractDoclet.start(com.sun.javadoc.RootDoc)
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at java.lang.reflect.Method.invoke(java.lang.Object, java.lang.Object[])
(/usr/lib/libgcj.so.6.0.0)
   at gnu.classpath.tools.gjdoc.Main.startDoclet(java.util.List)
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at gnu.classpath.tools.gjdoc.Main.start(java.lang.String[])
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at gnu.classpath.tools.gjdoc.Main.main(java.lang.String[])
(/usr/lib/lib-gnu-classpath-tools-gjdoc.so.0.0.0)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
25 warnings
Comment 5 Andrew Overholt 2005-05-01 12:46:59 EDT
Julian patched gjdoc so now the JDT API docs are included in 3.1.0_fc-0.M6.13. 
PDE docs don't seem to be there and neither do those under "Platform Plug-in
Developer Guide".  I'll have to look into why those aren't building.
Comment 6 Andrew Overholt 2005-05-04 11:22:30 EDT
I've narrowed this down a bit and emailed Julian.  Hopefully we can work
something out.
Comment 7 Andrew Overholt 2005-05-05 18:23:27 EDT
I think all the docs should be built in the forthcoming 3.1.0_fc-0.M6.15.  When
that comes out, please report back if things aren't as you expect.  Thanks again
to Julian for fixing the bugs we found.
Comment 8 Ben Konrath 2006-10-04 12:55:47 EDT
This has been fixed in FC5 and FC6, closing bug.

Note You need to log in before you can comment on or make changes to this bug.