Bug 15210 - Setting up slave YP servers
Summary: Setting up slave YP servers
Status: CLOSED DUPLICATE of bug 26362
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypserv   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-03 06:07 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-19 15:50:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-03 06:07:24 UTC
Problem occurs on i386 and alpha when trying to set up a slave server
on executing the command ypinit -s hostname.hostdomain
always get the error

Can't enumerate maps from $MASTER. Please check that it is running.
The script ypinit contains the lines

#  maps=`ypwhich -m | egrep $MASTER$| awk '{ printf("%s ",$1) }' -`
  maps=`$YPBINDIR/yphelper --maps $MASTER`

but yphelper is broken
The commneted out line is also broken and as an extra $ after master
If this is changed to 
  maps=`ypwhich -m | egrep $MASTER | awk '{ printf("%s ",$1) }' -`
#  maps=`$YPBINDIR/yphelper --maps $MASTER`

and /usr/sbin/rpc.ypxfrd is manually started on the host machine then a
slave server can be initialised

Comment 1 Florian La Roche 2000-08-07 14:22:11 UTC
ypinit is working fine for me without the above change. Can you tell me more
about the ypserver
and what ypserv version it has running?

Florian La Roche


Comment 2 djschaap 2000-08-24 15:30:51 UTC
I ran into the same problem.  By using strace, I discovered yphelper was polling
the first system listed in /etc/hosts, regardless of the NIS master passed to it
on the command line.  After I moved my NIS master to the first line of
/etc/hosts (on the client machine), yphelper ran just fine.

hth,
-Doug


Comment 3 Need Real Name 2000-08-25 00:49:31 UTC
on alpha and i386 machines

rpm -q ypserv
ypserv-1.3.9-3

/usr/sbin/ypserv --version
ypserv - NYS YP Server version 1.3.9 (with securenets)


Comment 4 Tim Clarke 2000-09-20 18:00:53 UTC
I had the same yphelper failure, but was able to run "/usr/lib/yp/ypinit -s
master_host" with no problems after flipping the comments around as detailed
above. I was using the same ypserv version as listed above.

Tim



Comment 5 Gordon Simon 2000-09-21 04:58:22 UTC
I have the same problem between two RedHat 6.2 servers.

I think the problem is mainly at the master server. When I pointed my slave 
server to an SCO OpenServer host (with NIS enabled), I indeed was able to 
configure the slave. But the same slave pointing to a RedHat 6.2 host 
(configured as a NIS master) would only generate the errors indicated in this 
report (namely, Can't enumerate maps from $MASTER. Please check that it is 
running.)

It seems that this error has been reported/discussed on the Web for some time ( 
I did some browsing looking for a solution). When is it going to get fixed ?


Comment 6 Steven Roberts 2002-01-24 03:39:23 UTC
FYI bug 26362 is also dealing with this issue (same state on 6.2 servers ypwhich workaround functions yphelper --maps doesn't)

Comment 7 Alexander Larsson 2002-03-21 15:48:11 UTC

*** This bug has been marked as a duplicate of 26362 ***

Comment 8 Alexander Larsson 2002-03-26 17:53:45 UTC
If anyone can reproduce this right now, please contact me.



Note You need to log in before you can comment on or make changes to this bug.