Bug 152119 - system-config-packages confused by "Failed dependencies" from rpm
system-config-packages confused by "Failed dependencies" from rpm
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 19:06 EST by Klaus Pedersen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:58:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Klaus Pedersen 2005-03-24 19:06:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
I wanted to remove "sendmail" from my install. I hoped that I could use system-config-packages to do so, but I was met with the following diagnostic I couldn't quite decode:

"Packages Not Found

The following packages could not be found on your system.  Installation cannot continue until they are installed.

... bla bla ..."


When I used rpm directly I got a more sensible message:

"rpm -e sendmail
error: Failed dependencies:
        /usr/sbin/sendmail is needed by (installed) redhat-lsb-1.3-10.i386
        smtpdaemon is needed by (installed) mdadm-1.9.0-1.i386
        smtpdaemon is needed by (installed) fetchmail-6.2.5-6.i386
        smtpdaemon is needed by (installed) mutt-1.4.2.1-2.i386"


Wouldn't it be a more correct behaviour if system-config-packages, told
me that the packages "redhat-lsb, mdadm, fetchmail and mutt" depended
on sendmail, so if I still wanted to remove sendmail, it would also
have to remove these packages?


Version-Release number of selected component (if applicable):
system-config-packages-1.2.21-2, rpm-4.4.1-7

How reproducible:
Always

Steps to Reproduce:
1. remove "sendmail" using system-config-packages (with lsb installed).
  

Actual Results:  I got an error saying:

"Packages Not Found

The following packages could not be found on your system.  Installation cannot continue until they are installed.

... bla bla ..."


Expected Results:  A dialog saying:

"The packages "redhat-lsb, mdadm, fetchmail and mutt" depended
on sendmail. These packages will also be removed..."



Additional info:
Comment 1 Jeremy Katz 2005-09-21 15:58:51 EDT
system-config-packages doesn't understand available updates which makes it
utility less than ideal.  The next generation tool whcih will be in Fedora Core
5 will resolve this problem

Note You need to log in before you can comment on or make changes to this bug.