Bug 152188 - k3b/growisofs hitting 100% CPU
k3b/growisofs hitting 100% CPU
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-25 15:47 EST by Paul F. Johnson
Modified: 2015-01-04 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 20:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
K3B burn log (9.91 KB, text/plain)
2005-04-07 11:13 EDT, Marco
no flags Details
K3b burn final splash screen (73.34 KB, image/jpeg)
2005-04-07 11:14 EDT, Marco
no flags Details

  None (edit)
Description Paul F. Johnson 2005-03-25 15:47:47 EST
Description of problem:
When creating either an iso image or just burning to DVD, either k3b or
growisofs (I suspect growisofs as it happens as well under nautilus-cd-burn)
hits 100% CPU. If anything else takes up too much CPU (such as X), the DVD burn
fails.

Version-Release number of selected component (if applicable):
k3b - 0.11.17-2
mkisofs - 2.01.1-8

How reproducible:
Always

Steps to Reproduce:
1. Load k3b
2. Either create an iso image or burn on the fly
3.
  
Actual results:
CPU hits 100% and any interference (such as the screensaver hitting in) cause
the DVD burn to fail

Expected results:
CPU usage should be up. On the my FC3 system at work (similar spec to my home
machine with test1 on), CPU usage for DVD burning is typically 24 - 35%.

Additional info:
Comment 1 Paul F. Johnson 2005-03-28 09:07:14 EST
Creating an iso and running growisofs by itself gave the following

Average CPU usage, 65% (peak around 73%)

The burn failed at 2.3% with the following report

:-( unable to WRITE@LBA=c940h: Input/output error
builtin_dd 51520*2KB out @ average 0.7x1385KBps
:-( write failed: Input/output error
/dev/hdf: flushing cache
:-( unable to FLUSH CACHE: Input/output error
:-[ SYNCHRONOUS FLUSH CACHE failed with SK=2h/ASC=04h/ACQ=01h]: Resource
temporarily unavailable

I've tested the burner on my sons FC2 box and it burned 10/10 discs placed in it.
Comment 2 Harald Hoyer 2005-03-29 06:58:03 EST
sounds like a kernel/driver/drive issue. Never heard of that...
Comment 3 Marco 2005-04-06 16:44:02 EDT
Tried K3B 0.11.23 in rawhide and/or newer firmware?
Comment 4 Paul F. Johnson 2005-04-06 16:53:07 EDT
I've tried the newer k3b, this seems to help as the CPU usage only hits about
65%, but the burn still fails.

I don't have the updated firmware. Is there any way to update it under linux?
Comment 5 Marco 2005-04-06 19:42:46 EDT
Which burner do you have?
Probably Windows is the only OS that can update firmware, only for bios I think
you can use a simple bootdisk.
Comment 6 Paul F. Johnson 2005-04-07 06:40:57 EDT
I'm using an NEC3500A (firmware revision 2.16 - current version is 2.19).

It was working fine under previous kernels, but not currently. It seems to die at 8%
Comment 7 Marco 2005-04-07 10:20:35 EDT
I have the same burner, I will try to make an ISO and I will tell you.
I have firmware 2.19
Comment 8 Marco 2005-04-07 11:08:07 EDT
Works for me:
I've made an ISO of Fedora Core test 1 DVD and burn again into the same DVD+RW

Making ISO heat a lot of cpu about 90%, burning less than 15%.

See attachments

Hope this help, probably you have to update the firmware.
Comment 9 Marco 2005-04-07 11:13:29 EDT
Created attachment 112810 [details]
K3B burn log
Comment 10 Marco 2005-04-07 11:14:56 EDT
Created attachment 112811 [details]
K3b burn final splash screen
Comment 11 Paul F. Johnson 2005-04-16 20:38:15 EDT
It seems happy again under the 1240_FC4 kernel. CPU usage is back down and the
drive will burn fine.

One good thing, the flash on the DVD can be updated with Linux :-)

Closing the bug
Comment 12 Marco 2005-04-17 15:26:06 EDT
(In reply to comment #11)
> One good thing, the flash on the DVD can be updated with Linux :-)


How? With Wine?
Comment 13 Paul F. Johnson 2005-04-17 15:40:45 EDT
No - I've found a flash burner (binary only) which works under Linux. Do a
google search for it.

Note You need to log in before you can comment on or make changes to this bug.