Bug 152199 - agpgart-serverworks fail on hp netserver lc 2000
agpgart-serverworks fail on hp netserver lc 2000
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-25 20:06 EST by Karl Latiss
Modified: 2015-01-04 17:18 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 04:49:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vvv (4.26 KB, text/plain)
2005-03-28 00:33 EST, Karl Latiss
no flags Details

  None (edit)
Description Karl Latiss 2005-03-25 20:06:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
I am seeing the following errors in dmesg upon boot and I don't think these boxes even _have_ agp:

Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Maximum main memory to use for agp memory: 941M
agpgart: unable to determine aperture size.
agpgart: agp_backend_initialize() failed.
agpgart-serverworks: probe of 0000:00:00.0 failed with error -22
agpgart: Maximum main memory to use for agp memory: 941M
agpgart: unable to determine aperture size.
agpgart: agp_backend_initialize() failed.
agpgart-serverworks: probe of 0000:00:00.1 failed with error -22


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-5.0.3.EL

How reproducible:
Always

Steps to Reproduce:
1.boot
2.see error
3.
  

Actual Results:  error in dmesg

Expected Results:  no errors and no use of agp

Additional info:

output of lspci:

00:00.0 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:00.1 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
00:04.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
00:05.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC (rev 7a)
00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 50)
00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller
03:06.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1010 Ultra3 SCSI Adapter (rev 01)
03:06.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1010 Ultra3 SCSI Adapter (rev 01)
Comment 1 Dave Jones 2005-03-26 21:56:02 EST
one of your host bridges must have AGP capabilities (lspci -vvv will tell you),
even if the box physically has no slots. It's a little difficult to detect this
situation unfortunatly.
I'll see if I can hardcode a check for that particular failure in the
serverworks driver, and silence the warnings..
Comment 2 Karl Latiss 2005-03-28 00:31:58 EST
lspci -vvv (attached) indeed does show agp capabilities and in fact the onboard
card reports itself as an agp card. Who would have thunk!

That being the case I wonder why I see the errors then?
Comment 3 Karl Latiss 2005-03-28 00:33:14 EST
Created attachment 112383 [details]
output of lspci -vvv
Comment 4 Jason 2005-04-18 11:49:15 EDT
This is a duplicate of bug 124593 which was closed earlier.  This problem has
been around since FC2.  This bug is in FC3 and RHEL 3 too.
Comment 5 Dave Jones 2005-09-30 04:49:52 EDT
the lack of specs on this chipset make it pretty much impossible to come up with
any workaround.  Silencing the warning is actually quite invasive too, as it
involves interpreting return codes across two modules in a generic routine.

The warning is however totally harmless, so for rhel4, I'm not going to change
this, for fear of breaking any working setups (as well as undocumented, that
driver is quite fragile in parts)  Hopefully at some point I'll come up with
something upstream that will be done in time for rhel5.

Note You need to log in before you can comment on or make changes to this bug.