Bug 152220 - "Unresolvable chain of dependencies" error for mozilla-1.7.6-1.2.2
"Unresolvable chain of dependencies" error for mozilla-1.7.6-1.2.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 11:02 EST by Tim Bingham
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 04:31:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Bingham 2005-03-26 11:02:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3

Description of problem:
mozilla 1.7.6 1.2.2  depends on desktop-file-utils >= 0.9 but desktop-file-utils-0.4-2 is latest this results in "Unresolvable chain of dependencies:" errors.

Please see log below.

Thanks,
Tim.

# up2date -u
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-2
using mirror: http://download.fedora.redhat.com/pub/fedora/linux/core/2/i386/os/http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc2
using mirror: http://ftp.dulug.duke.edu/pub/fedora/linux/core/updates/2/i386/
 
Fetching Obsoletes list for channel: fedora-core-2...
 
Fetching Obsoletes list for channel: updates-released-fc2...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
mozilla                                 1.7.6          1.2.2             i386
mozilla-nspr                            1.7.6          1.2.2             i386
mozilla-nss                             1.7.6          1.2.2             i386
 
 
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:
 
Unresolvable chain of dependencies:
mozilla-1.7.6-1.2.2                      requires desktop-file-utils >= 0.9
 
[root@tjbibm tjb]# up2date -u desktop-file-utils
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-2
using mirror: http://rpmfind.net/linux/fedora/core/2/i386/os/
http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc2
using mirror: http://rpmfind.net/linux/fedora/core/updates/2/i386/
 
Fetching Obsoletes list for channel: fedora-core-2...
 
Fetching Obsoletes list for channel: updates-released-fc2...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
 
All packages are currently up to date
[root@tjbibm tjb]# rpm --query --all | grep desktop-file-utils
desktop-file-utils-0.4-2
#



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. "u2date -u"
2.
3.
  

Actual Results:  Unresolvable chain of dependencies:
mozilla-1.7.6-1.2.2                      requires desktop-file-utils >= 0.9
 


Expected Results:  mozilla-1.7.6-1.2.2 is installed without errors

Additional info:
Comment 1 Richard Bullington-McGuire 2005-03-26 11:11:24 EST
Perhaps this should marked as a security bug and escalated, since it is stopping
FC2 machines from applying errata automatically if they have mozilla installed?

I've received the same sort of error when attempting to use yum to update my system:

[root@sargon rbulling]# yum -y update
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Dag RPM Repository for Fedora Core
Server: Fedora Linux 2 - i386 - freshrpms
Server: JPackage 1.5 development RPMS (PKR Internet only)
Server: JPackage 1.5 non-free RPMs (PKR Internet only)
Server: JPackage 1.5 for Fedora Core 2
Server: JPackage 1.5, generic
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Resolving dependencies
......Unable to satisfy dependencies
Package mozilla needs desktop-file-utils >= 0.9, this is not available.

Comment 2 Warren Togami 2005-03-27 18:44:22 EST
We made a mistake and added the FC3 desktop-file-utils version dep to the FC2
mozilla update.

http://people.redhat.com/wtogami/temp/mozilla/
Please verify that the candidate update packages here works on FC2 with the FC2
standard desktop-file-utils.
Comment 3 Tim Bingham 2005-03-27 20:22:22 EST
> Please verify that the candidate update packages here works on FC2 with the FC2
> standard desktop-file-utils.

I downloaded and intalled mozilla-1.7.6-1.2.3.i386.rpm
mozilla-nss-1.7.6-1.2.3.i386.rpm mozilla-nspr-1.7.6-1.2.3.i386.rpm from
http://people.redhat.com/wtogami/temp/mozilla/i386 and those packages seem to
install (apart from a "command not found" error) and run properly

# rpm --upgrade mozilla-1.7.6-1.2.3.i386.rpm mozilla-nss-1.7.6-1.2.3.i386.rpm
mozilla-nspr-1.7.6-1.2.3.i386.rpm
/var/tmp/rpm-tmp.29659: line 1: update-desktop-database: command not found
#
Comment 4 Richard Bullington-McGuire 2005-03-27 21:24:54 EST
The candidate update packages install, but the RPM script calls
update-desktop-database, a program included in the FC3 desktop-file-utils, but
not in FC2.

# rpm -Uvh mozilla-nspr-1.7.6-1.2.3.i386.rpm mozilla-chat-1.7.6-1.2.3.i386.rpm
mozilla-nss-1.7.6-1.2.3.i386.rpm mozilla-js-debugger-1.7.6-1.2.3.i386.rpm
mozilla-1.7.6-1.2.3.i386.rpm mozilla-mail-1.7.6-1.2.3.i386.rpm
Preparing...                ########################################### [100%]
   1:mozilla-nspr           ########################################### [ 17%]
   2:mozilla-nss            ########################################### [ 33%]
   3:mozilla                ########################################### [ 50%]
/var/tmp/rpm-tmp.33363: line 1: update-desktop-database: command not found
   4:mozilla-mail           ########################################### [ 67%]
   5:mozilla-chat           ########################################### [ 83%]
   6:mozilla-js-debugger    ########################################### [100%]
[root@sargon mz]# locate update-desktop-database
[root@sargon mz]#

As for whether the new packages Actually Work, I'll let you know (I'm still
runing the old binaries as I post this).
Comment 5 Richard Bullington-McGuire 2005-03-27 21:34:29 EST
OK, despite the command not found warning on install, Mozilla 1.7.6 seems to be
working Just Fine. It continues to launch from the GNOME desktop start button.
Comment 6 Warren Togami 2005-03-27 21:45:01 EST
Good thing we tested it before pushing, uploaded another candidate -1.2.4 which
is the same thing except removed update-desktop-database
Comment 7 Warren Togami 2005-03-28 03:39:08 EST
http://people.redhat.com/wtogami/temp/mozilla/
Updated once more as -1.2.5 to fix the gtk system colors.  Will push this to
updates after someone tests it and reports back.
Comment 8 James Juran 2005-03-28 08:53:15 EST
Installed mozilla-1.7.6-1.2.5.i386.rpm, mozilla-nss-1.7.6-1.2.5.i386.rpm, and
mozilla-nspr-1.7.6-1.2.5.i386.rpm with no errors and they seem to be working
correctly.
Comment 9 Kai Engert (:kaie) 2005-03-29 04:16:54 EST
I can confirm, too, the packages available currently on
http://people.redhat.com/wtogami/temp/mozilla/ installed on my fc2 system
correctly without warnings (did "rpm -Fvh" on the command line). Browser works.
Comment 10 Warren Togami 2005-03-29 04:31:20 EST
Issued in FC2 updates.

Note You need to log in before you can comment on or make changes to this bug.