Bug 152258 - Autofs looks for spurious /net mounts
Autofs looks for spurious /net mounts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 17:29 EST by Adam Huffman
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: autofs-4.1.4-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-16 19:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/auto.net (1.04 KB, text/plain)
2005-04-18 20:20 EDT, Adam Huffman
no flags Details

  None (edit)
Description Adam Huffman 2005-03-26 17:29:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
NFS mounts in /net are hanging for a while, owing to some strange lookups
by the auto.net script:

Mar 26 20:42:58 charlus automount[7521]: >> /usr/sbin/showmount: can't get address for 192.168.0.10/maxtor250/libpthread.so.0
Mar 26 20:42:58 charlus automount[7521]: lookup(program): lookup for 192.168.0.10/maxtor250/libpthread.so.0 failed
Mar 26 20:42:58 charlus automount[7521]: failed to mount /net/192.168.0.10/maxtor250/libpthread.so.0
Mar 26 20:42:58 charlus automount[7537]: >> /usr/sbin/showmount: can't get address for 192.168.0.10/maxtor250/i686
Mar 26 20:42:58 charlus automount[7537]: lookup(program): lookup for 192.168.0.10/maxtor250/i686 failed
Mar 26 20:42:58 charlus automount[7537]: failed to mount /net/192.168.0.10/maxtor250/i686
Mar 26 20:43:20 charlus automount[7542]: >> /usr/sbin/showmount: can't get address for 192.168.0.10/maxtor250/libattr.so.1
Mar 26 20:43:20 charlus automount[7542]: lookup(program): lookup for 192.168.0.10/maxtor250/libattr.so.1 failed
Mar 26 20:43:20 charlus automount[7542]: failed to mount /net/192.168.0.10/maxtor250/libattr.so.1

This means than running 'ls' in the /net/192.168.0.10 directory hangs for a couple of minutes.  Changing to one of the directories inside the mount works,
most of the time, without delay.

This has only started happening in the past day or so, which means it must have come in one of the recent updates.


Version-Release number of selected component (if applicable):
autofs-4.1.3-28

How reproducible:
Always

Steps to Reproduce:
1. change to a /net mounted directory
2. ls
3.
  

Actual Results:  That login hangs for several minutes

Expected Results:  The contents of the remote directory should be listed.

Additional info:
Comment 1 Jeffrey Moyer 2005-03-31 12:30:57 EST
I suspect this has been addressed in a later version of the package.  I'll work
to get a newer version into FC3.  If you are so inclined, you could grab the
srpm from rawhide and build that.  Otherwise, I'll let you know when a new
version is available.
Comment 2 Chris Feist 2005-04-11 15:00:50 EDT
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/3/i386/autofs-4.1.3-114.i386.rpm

You can find a test version of the fc3 autofs package at the URL above.  Please
try it out and let us know if it fixes your problem.
Comment 3 Adam Huffman 2005-04-12 19:42:58 EDT
Have just tried that new version and the problem is still there, e.g.:

7539 pts/5    S      0:00 /bin/sh /etc/auto.net 192.168.0.10/libpthread.so.0
7540 pts/5    S      0:00 /usr/sbin/showmount --no-headers -e
192.168.0.10/libpthrea 
7541 pts/5    S      0:00 sort +0
7542 pts/5    S      0:00 awk -v key=192.168.0.10/libpthread.so.0 -v opts=-fstype=nf
Comment 4 Chris Feist 2005-04-13 11:24:44 EDT
Can you post your /etc/auto.master, the output from '/etc/auto.net 192.168.0.10'
& your /etc/auto.net file.
Comment 5 Adam Huffman 2005-04-18 20:19:49 EDT
/etc/auto.master:

/net    /etc/auto.net

The command output:

-fstype=nfs,hard,intr,nodev,nosuid,uid=500 \
        /home/adam 192.168.0.10:/home/adam \
        /maxtor250/adam 192.168.0.10:/maxtor250/adam
Comment 6 Adam Huffman 2005-04-18 20:20:55 EDT
Created attachment 113350 [details]
/etc/auto.net
Comment 7 Jeffrey Moyer 2006-04-17 17:39:55 EDT
This sounds like the buggy negative dentry caching problem.  This has been fixed
in recent kernels.  Can you re-test with the latest bits?  I'll attach the patch
that fixed things.
Comment 8 Jeffrey Moyer 2006-04-17 17:42:19 EDT
Can't find the patch kicking around on my system anymore.  Here is a link to a
mailing list post with the patch:

http://hera.kernel.org/pipermail/autofs/2006-January/002836.html
Comment 9 John Thacker 2006-05-05 10:57:19 EDT
Closing due to no response.  Should be fixed in recent kernels.
Comment 10 Adam Huffman 2006-05-12 20:23:09 EDT
There's still a problem with the latest FC5 updates - I have to restart the
autofs service in order for it to work.  
Comment 11 Jeffrey Moyer 2006-05-15 09:32:10 EDT
OK, can you collect some debugging information?  Take a look at the section
entitled "Filing bug reports" at the following URL:
  http://people.redhat.com/jmoyer/

The debug logs are really what I'm looking for.

Thanks!
Comment 12 Adam Huffman 2006-05-16 19:52:42 EDT
Actually, I take that back - it does seem to be working now.  

Thanks for taking a look.
Comment 13 Adam Huffman 2007-02-01 19:02:21 EST
I'm actually having other problems with autofs now, listed in bug #271665.

Note You need to log in before you can comment on or make changes to this bug.