This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 152264 - Edit Toolbars in epiphany crashes browser
Edit Toolbars in epiphany crashes browser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 18:51 EST by Glen Kim
Modified: 2014-12-03 06:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-16 01:30:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 159767 None None None Never

  None (edit)
Description Glen Kim 2005-03-26 18:51:48 EST
Selecting Edit->Toolbars from the menu bar causes epiphany to crash.  On the
terminal, it outputs the following:

(epiphany:9130): Gdk-CRITICAL **: gdk_drawable_set_colormap: assertion `cmap ==
NULL || gdk_drawable_get_depth (drawable) == cmap->visual->depth' failed

(epiphany:9130): Gdk-WARNING **: gdkpixbuf-drawable.c:1249: Source drawable has
no colormap; either pass in a colormap, or set the colormap on the drawable with
gdk_drawable_set_colormap()

(epiphany:9130): Gdk-CRITICAL **: gdk_drawable_set_colormap: assertion `cmap ==
NULL || gdk_drawable_get_depth (drawable) == cmap->visual->depth' failed

(epiphany:9130): Gdk-WARNING **: gdkpixbuf-drawable.c:1249: Source drawable has
no colormap; either pass in a colormap, or set the colormap on the drawable with
gdk_drawable_set_colormap()
The program 'epiphany' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 3853 error_code 8 request_code 70 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


[glen@dandelion ~]$ rpm -q epiphany
epiphany-1.5.8-3
Comment 1 Glen Kim 2005-03-26 19:00:49 EST
Also, this bug happens only when the Composite extension is enabled.
Comment 2 sangu 2005-03-28 05:04:20 EST
$XLIB_SKIP_ARGB_VISUALS=1 epiphany

https://bugs.freedesktop.org/show_bug.cgi?id=1145
Comment 3 sangu 2005-03-28 05:07:22 EST
bug 132044 has been marked as a duplicate of this bug.
Comment 4 Matthias Clasen 2006-02-16 01:30:34 EST
Works fine for me with current epiphany, and with Composite turned on.

Note You need to log in before you can comment on or make changes to this bug.