Bug 152272 - "[-x: command not found" error when installing current devel rpms
"[-x: command not found" error when installing current devel rpms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 21:24 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 05:05:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-03-26 21:24:40 EST
A bunch of current devel RPMs are reporting this upon install:

/var/tmp/rpm-tmp.42427: line 9: [-x: command not found

I managed to capture an rpm-tmp file with the problem and found that it's this
bit of code that's causing it:

if [-x /usr/bin/gtk-update-icon-cache ]; then
  gtk-update-icon-cache /usr/share/icons/hicolor
fi

There needs to be a space before the "-x".  I suspect a recent change in
rpm-build but can't know for certain.
Comment 1 Jeff Johnson 2005-03-26 22:58:02 EST
Bzzzzt! Packaging, not rpmbuild, problem.
Comment 2 Jonathan Kamens 2005-03-26 23:48:51 EST
This is certainly a bug, even if isn't an RPM bug, so CLOSED/NOTABUG is not the
appropriate status to assign to it.

I got this error from 18 different packages:

   9:system-config-language ########################################### [ 18%]
/var/tmp/rpm-tmp.47911: line 2: [-x: command not found
  10:system-config-kickstart########################################### [ 20%]
/var/tmp/rpm-tmp.94093: line 2: [-x: command not found
  12:system-config-samba    ########################################### [ 24%]
/var/tmp/rpm-tmp.25533: line 2: [-x: command not found
  19:gimp                   ########################################### [ 38%]
/var/tmp/rpm-tmp.26074: line 7: [-x: command not found
  20:gnome-panel            ########################################### [ 40%]
/var/tmp/rpm-tmp.74540: line 2: [-x: command not found
  24:vnc                    ########################################### [ 48%]
/var/tmp/rpm-tmp.18537: line 2: [-x: command not found
  28:system-config-users    ########################################### [ 56%]
/var/tmp/rpm-tmp.62297: line 2: [-x: command not found
  29:system-config-soundcard########################################### [ 58%]
/var/tmp/rpm-tmp.38213: line 2: [-x: command not found
  30:system-config-services ########################################### [ 60%]
/var/tmp/rpm-tmp.616: line 2: [-x: command not found
  31:system-config-rootpassw########################################### [ 62%]
/var/tmp/rpm-tmp.32953: line 2: [-x: command not found
  32:system-config-nfs      ########################################### [ 64%]
/var/tmp/rpm-tmp.30054: line 2: [-x: command not found
  33:system-config-keyboard ########################################### [ 66%]
/var/tmp/rpm-tmp.18183: line 2: [-x: command not found
  34:system-config-display  ########################################### [ 68%]
/var/tmp/rpm-tmp.85350: line 2: [-x: command not found
  35:system-config-date     ########################################### [ 70%]
/var/tmp/rpm-tmp.47114: line 2: [-x: command not found
  38:hicolor-icon-theme     ########################################### [ 76%]
/var/tmp/rpm-tmp.7364: line 2: [-x: command not found
  39:gdm                    ########################################### [ 78%]
/var/tmp/rpm-tmp.42598: line 4: [-x: command not found
  44:desktop-printing       ########################################### [ 88%]
/var/tmp/rpm-tmp.57506: line 2: [-x: command not found
  45:control-center         ########################################### [ 90%]
/var/tmp/rpm-tmp.42427: line 9: [-x: command not found

Perhaps it isn't rpmbuild in particular that's broken, but surely there is
*some* central package that is causing the problem, because it seems highly
unlikely that the maintainers of at least 18 separate packages all made the same
packaging error within a few days of each other, eh?

When I start to look at their changelog entries, I see this at the top of all of
them:

* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com>
- Update the GTK+ theme icon cache on (un)install

It would seem that Mr. Aillon has some clean-up to do of an unfortunate error. 
I'm not about to create tickets for 18 different packages, but I'll move this
ticket to the first package I got the error in and perhaps he will do the right
thing and fix all the packages he broke.
Comment 3 Robert Scheck 2005-03-27 05:42:45 EST
This bug is a duplicate of bug #152233, already described there.
"[ -x" rather "[-x" and the possible output of gtk-update-icon-cache should be
redirected to ">> /dev/null"
Comment 4 David Lawrence 2005-03-27 13:35:05 EST
Problem still occuring in latest rawhide (2005-03-27)

Note You need to log in before you can comment on or make changes to this bug.