Bug 152296 - yum search matches gpg fingerprints
yum search matches gpg fingerprints
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-27 14:29 EST by Need Real Name
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 17:10:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-27 14:29:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
yum search qt matches gpg fingerprints which contain "qt"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Actual Results:  match on fingerprint

Expected Results:  no match on fingerprint

Additional info:
Comment 1 Seth Vidal 2005-03-27 16:21:29 EST
why is this a bug? Why shouldn't yum search match against gpg keys?

Comment 2 Need Real Name 2005-03-28 01:14:47 EST
Because a yum search for short package names will match gpg keys.

I can't see why someone would want to search for a short number of letters (say
five) in a gpg key.

I can see that searching for a gpg key might be useful (is this an edge case?),
but it seems mushc less useful to match a two letter portion of a gpg key than a
package name.
Comment 3 Need Real Name 2005-06-20 17:06:30 EDT
How is this not a bug? In what case would you need to search for a partial gpg
fingerprint?
Comment 4 Seth Vidal 2005-06-20 17:10:13 EDT
excluding them is just a bizarre piece of code to write. ESPECIALLY when you
think that someone might actually want to search for a gpg key.

re-closing.

Comment 5 Need Real Name 2005-06-21 02:29:53 EDT
Seth - this is ridiculous.

The bug was opened because a search for "qt" matches bits of gpg fingerprints.
I've given a clear example of where the current search doesn't work.

Where is the case when matching a partial gpg fingerprint, rather than a whole
one, is useful?
Comment 6 Seth Vidal 2005-06-21 02:31:32 EDT
Where is the case when it is not? More importantly where is the case for writing
code to preclude this?

Comment 7 Need Real Name 2005-06-21 02:38:57 EDT
(In reply to comment #6)
> Where is the case when it is not?
yum search qt

>More importantly where is the case for writing code to preclude this?
Because it doesn't do what it says on the tin.
Comment 8 Seth Vidal 2005-06-21 02:41:32 EDT
It does EXACTLY what it says on the tin.

it searches for 'qt' in the package description, summary and name.
Comment 9 Need Real Name 2005-06-21 03:15:40 EDT
..and pgp public key blocks.

$ yum search qt|grep -i qt
[snip]
bc67qTd1zASiefGjf364j4lQd+X9AqdyhUrnax3UgPD5IxilBp92Cw7Qi7QzRmVkb3JhIFBy
QF6e+q4AmwVus4u9REyd/aigK2RvrdtcsNy0iEYEExECAAYFAj+dpBoACgkQtEJp0E8qb9Ji
AAYFAj+dnTwACgkQtEJp0E8qb9L//gCcDVYnDegNCOxDn1sedDwxw+0h8OcAn1CZHof15Qqx
fCZg1gu1sPFV3GSa+Y/7jsiLktQvCiLPlncQt1dV+ENmHR5BdIDPWDzKBVbgWnSDnqQ6KrZ7
/VGo2Jr8mhLUqoIbE6zeGAmZbUpdckDco8D5fiFmqTf5+++pCEpJLJkkzel/32N2w4qzPrcR
ZSBFeHRyYXMgUmVsZWFzZSA8cHJlLWV4dHJhc0BmZWRvcmFwcm9qZWN0Lm9yZz6IXgQTEQIA
QmnQTypv0lVYAJoCLolPSuAj873GbV2+m3Bj6sS/UACeNcDmIWeruRld83uSQcx4xJyEOUa0
HXr29gNAbLwAoJVqJWvgBIvg8/4MiqwKAQ1MDkIUiEYEEhECAAYFAkIA/wQACgkQtEJp0E8q
cmEgUHJvamVjdCA8ZmVkb3JhLWV4dHJhc0BmZWRvcmFwcm9qZWN0Lm9yZz6IXgQTEQIAHgUC
QQZwvs7e/J4//QCeM3nDwC5EfEbEtOHPIYAqTf3IQZaIRgQSEQIABgUCQgD/BAAKCRC0QmnQ
+gGasLmdxY+xk5AUB7gLt4mseKsWyHvQt+H4wG8jjOjHWXlaJkZaYQUxpVPd6/11hkoqpodJ
Comment 10 Seth Vidal 2005-06-21 08:21:10 EDT
the gpg public key blog is IN the description

rpm -qi gpg-pubkey

Comment 11 Need Real Name 2005-06-21 09:46:14 EDT
That may be, but we still don't have a reason why matching a bit of a gpg
fingerprint is useful.
Comment 12 Seth Vidal 2005-06-21 09:49:06 EDT
And I haven't, yet, seen a convincing reason for writing and maintaining extra
code to preclude the gpg pubkeys.
Comment 13 Need Real Name 2005-06-21 10:26:07 EDT
Well it's probably fair to say that including a gpg key in a description is a
bug, since a gpg key is by definition not a description.

If a user wants to search for a package, for example "qt" then they should not
have packages which match parts of gpg keys returned to them. There are
apparently no cases where matching bits of gpg keys is useful, and since this
conflicts with the ability to search for a particular package, it should go.

Is there any way to get a super review on this bug? We seem to be going round in
circles.
Comment 14 Seth Vidal 2005-06-21 10:30:22 EDT
okay then I'll say this:

I WANT TO SEARCH FOR GPG KEYS

Now, there's a use case. 

Second, I'm in charge of yum. I am the super review on this bug. I don't work
for red hat and you won't be able to find a supervisor of me about yum.

Don't even try to find anyone to pull rank on me about this. B/c there is no one.


Comment 15 Need Real Name 2005-06-21 10:42:25 EDT
Seth, please calm down.

You want to search for gpg keys. I want to search for package names.
yum does both of these, and they're both good options.

But yum also has a misfeature whereby it will match portions of a gpg key - this
is the case where it's not useful, and is causing me a problem.

The gpg key is always wrapped in a
 -----BEGIN PGP PUBLIC KEY BLOCK-----
 -----END PGP PUBLIC KEY BLOCK-----
block. Can't partial matches on this block be ignored?
Comment 16 Seth Vidal 2005-06-21 10:44:21 EDT
you've never explained how this causes a problem.




Comment 17 Need Real Name 2005-06-21 10:57:35 EDT
Imagine you're a new user to Fedora, you've just installed version 4, the latest
and greatest after a suggestion from your colleague.

First question: "Great! Looks good. Now how do I install extra stuff?"
Response: "The gui way is coming in the next version of Fedora. You can install
new packages by using a terminal window, just run yum search packagename."
Potential convert: "Okay. Hm, let me see..

$ yum search qt
Searching Packages:
Setting up repositories
Reading repository metadata in from local files


uim.i386                                 0.4.6-3                extras
Matched from:
Uim is a multilingual input method library. Uim aims to
provide secure and useful input methods for all
languages. Currently, it can input to applications which
support Gtk+'s immodule, Qt's immodule and XIM.

This package provides the input method library, the XIM
bridge and most of the input methods.

For the Japanese input methods you need to install
- uim-anthy for Anthy
- uim-canna for Canna
- uim-skk for SKK.


scribus.i386                             1.2.1-5                extras
Matched from:
DeskTop Publishing application written in Qt


qca.i386                                 1.0-5                  extras
Matched from:
Qt Cryptographic Architecture
Taking a hint from the similarly-named Java Cryptography Architecture,
QCA aims to provide a straightforward and cross-platform crypto API,
using Qt datatypes and conventions. QCA separates the API from the
implementation, using plugins known as Providers. The advantage of this
model is to allow applications to avoid linking to or explicitly depending
on any particular cryptographic library. This allows one to easily change
or upgrade crypto implementations without even needing to recompile the
application!


qca-tls.i386                             1.0-4                  extras
Matched from:
TLS plugin for the Qt Cryptographic Architecture
This is a plugin to provide SSL/TLS capability to programs that use the Qt
Cryptographic Architecture (QCA).  QCA is a library providing an easy API
for several cryptographic algorithms to Qt programs.  This package only
contains the TLS plugin.


qtparted.i386                            0.4.4-3                extras
Matched from:
qtparted
Partition Magic clone written in C++ using the Qt toolkit
QTParted is a Partition Magic clone written in C++ using the Qt toolkit.
http://qtparted.sourceforge.net/


aqhbci-qt-tools.i386                     1.0.1beta-5            extras
Matched from:
aqhbci-qt-tools
This package contains the QT setup wizard and a debugger for the HBCI backend
for the Aqbanking library which implements a client for the German HBCI
(Home Banking Computer Interface) protocol.


qca-devel.i386                           1.0-5                  extras
Matched from:
Qt Cryptographic Architecture development files


camstream.i386                           0.26.3-8               extras
Matched from:
CamStream is (going to be) a collection of tools for webcams and other
video-devices, enhancing your Linux system with multimedia video.
All written in C++ and with a nice GUI frontend. The interface
is based on Qt, an excellent GUI framework.


gtk-qt-engine.i386                       0.41-6                 extras
Matched from:
gtk-qt-engine
Allow GTK to use Qt widget styles
The GTK-Qt Theme Engine is a project allowing GTK to use Qt widget styles.

It behaves like a normal GTK theme engine, but calls functions from Qt
instead of doing the drawing itself.
http://www.freedesktop.org/Software/gtk-qt


pinentry-qt.i386                         0.7.1-4                extras
Matched from:
pinentry-qt
Passphrase/PIN entry dialog based on Qt
Pinentry is a collection of simple PIN or passphrase entry dialogs which
utilize the Assuan protocol as described by the aegypten project; see
http://www.gnupg.org/aegypten/ for details.
This package contains the Qt GUI based version of the PIN entry dialog.


uim-qt.i386                              0.4.6-3                extras
Matched from:
uim-qt
Qt support for Uim
Uim is a multilingual input method library. Uim aims to
provide secure and useful input methods for all

This package provides the Qt IM module and helper programs.


psi.i386                                 0.9.3-4.fc4            extras
Matched from:
Jabber client using Qt 3


gwenview.i386                            1.2.0-4.fc4            extras
Matched from:
Gwenview is an image viewer for KDE.

It features a folder tree window and a file list window to provide easy
navigation in your file hierarchy.  Image loading is done by the Qt library,
so it supports all image formats your Qt installation supports.


SoQt.i386                                1.2.0-6.fc4            extras
Matched from:
SoQt
SoQt is a Qt GUI component toolkit library for Coin.  It is also compatible
with SGI and TGS Open Inventor, and the API is based on the API of the
InventorXt GUI component toolkit.


SoQt-devel.i386                          1.2.0-6.fc4            extras
Matched from:
SoQt-devel
Development files for SoQt
Development package for SoQt


iiimf-qt.i386                            1:12.2-4               base
Matched from:
iiimf-qt
Qt Input Method module
Qt Input Method module for iiimf.


qt.i386                                  1:3.3.4-14             base
Matched from:
qt
The shared library for the Qt GUI toolkit.
Qt is a GUI software toolkit which simplifies the task of writing and
maintaining GUI (Graphical User Interface) applications
for the X Window System.

Qt is written in C++ and is fully object-oriented.

This package contains the shared library needed to run qt
applications, as well as the README files for qt.


qt-config.i386                           1:3.3.4-14             base
Matched from:
qt-config
Grapical configuration tool for programs using Qt
Qt is a GUI software toolkit which simplifies the task of writing and
maintaining GUI (Graphical User Interface) applications
for the X Window System.

Qt is written in C++ and is fully object-oriented.

This package contains a grapical configuration tool for programs using Qt.


qt-devel.i386                            1:3.3.4-14             base
Matched from:
qt-devel
Development files and documentation for the Qt GUI toolkit.
The qt-devel package contains the files necessary to develop
applications using the Qt GUI toolkit: the header files, the Qt meta
object compiler, the man pages, the HTML documentation and example
programs.

Install qt-devel if you want to develop GUI applications using the Qt
toolkit.


qt-ODBC.i386                             1:3.3.4-14             base
Matched from:
qt-ODBC
ODBC drivers for Qt's SQL classes.
ODBC driver for Qt's SQL classes (QSQL)


qt-MySQL.i386                            1:3.3.4-14             base
Matched from:
qt-MySQL
MySQL drivers for Qt's SQL classes.
MySQL driver for Qt's SQL classes (QSQL)


qt-PostgreSQL.i386                       1:3.3.4-14             base
Matched from:
qt-PostgreSQL
PostgreSQL drivers for Qt's SQL classes.
PostgreSQL driver for Qt's SQL classes (QSQL)


qt-designer.i386                         1:3.3.4-14             base
Matched from:
qt-designer
Interface designer (IDE) for the Qt toolkit
The qt-designer package contains an User Interface designer tool
for the Qt toolkit.


PyQt.i386                                3.14.1-1               base
Matched from:
PyQt
Python bindings for Qt
These are Python bindings for Qt.
http://www.riverbankcomputing.co.uk/pyqt/


PyQt-devel.i386                          3.14.1-1               base
Matched from:
PyQt-devel
Files needed to build other bindings based on Qt
Files needed to build other bindings for C++ classes that inherit from any
of the Qt classes (e.g. KDE or your own).
http://www.riverbankcomputing.co.uk/pyqt/


PyQt-examples.i386                       3.14.1-1               base
Matched from:
PyQt-examples
Examples for PyQt
Examples code demonstrating how to use the Python bindings for Qt.
http://www.riverbankcomputing.co.uk/pyqt/


sip.i386                                 4.2.1-1                base
Matched from:
SIP is a tool for generating bindings for C++ classes so that they can be
accessed as normal Python classes.  SIP takes many of its ideas from SWIG but,
because it is specifically designed for C++ and Python, is able to generate
tighter bindings.  SIP is so called because it is a small SWIG.

SIP was originally designed to generate Python bindings for KDE and so has
explicit support for the signal slot mechanism used by the Qt/KDE class
libraries.  However, SIP can be used to generate Python bindings for any C++
class library.


gpg-pubkey.None                          30c9ecf8-3f9da3f7      installed
Matched from:
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: rpm-4.4.1 (beecrypt-3.0.0)

mQGiBD+do/cRBACAF7Gv91v32uUrT4nZe+qKgLl59HmtvmaOzT4lInrF95Sget7p2TpnIqh5
H0x0VGpdoeNfHvlXCw+aP50mTJv91BYmLfelkTzokqpEU5YpqGOqa5BVjelnoK1VKOcXMB28
d79Gz9tn7friZN4SnyWbcSIA4C3dHNhsjifIYf0rywCg3y193N6jODa0VSGeeEb4whE2xccD
/i/rqk0MQmW6td2Dz2jTBaHxyf7FIcH18YDtwraDotBRxqGkTVyFGc1q7ZTrRsbzdjIfxbp2
C6GT2VJ5kHuRm9jf7JdW5fOhun+oLimRerTlrPmgz8qQRcqUm6fkmUsYufL1u7DdyfxX7jI2
ngkbAR+CsZ8Cj5JhBMeAXc/DWWhPA/4mzZ70hn1OrGLokzxNr4O7u1+n0thsxGN0qfuTNGIc
09UKCoAN42he7QjskIqiE7gLtLzx8elxVOK19tNcaAiLoqmtxlLQqB03pLy4V0tMP9QcWQET
bc67qTd1zASiefGjf364j4lQd+X9AqdyhUrnax3UgPD5IxilBp92Cw7Qi7QzRmVkb3JhIFBy
b2plY3QgKFRlc3QgU29mdHdhcmUpIDxyYXdoaWRlQHJlZGhhdC5jb20+iFsEExECABsFAj+d
o/cGCwkIBwMCAxUCAwMWAgECHgECF4AACgkQ2oTL1DDJ7Pgh8QCgqNNsb7xdW+UhzyZw+DEA
QF6e+q4AmwVus4u9REyd/aigK2RvrdtcsNy0iEYEExECAAYFAj+dpBoACgkQtEJp0E8qb9Ji
4QCfanY0CXnRwtBnm8GEMRNqgfGgcc0AnRunlejpJRxGPaRsmY/11stYll32iEYEEBECAAYF
Aj+e2SIACgkQKdW6JI31bQWWNQCfTKcX/7lerpwIVHcAILDduz9qxssAn1t46ERJ9EqsxJxS
FlN7oBPyNkt6
=R9He
-----END PGP PUBLIC KEY BLOCK-----



gpg-pubkey.None                          4f2a6fd2-3f9d9d3b      installed
Matched from:
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: rpm-4.4.1 (beecrypt-3.0.0)

mQGiBD+dnTsRBACwnlz4AhctOLlVBAsq+RaU82nb5P3bD1YJJpsAce1Ckd2sBUOJD11NUCqH
8c7EctOquOZ5zTcWxHiWWbLyKQwUw2SUvnWa5SSbi8kI8q9MTPsPvhwtgMrQMLenMO+nsrxr
SaG6XcD+ssfJNxC7NQVCQAj3pvvg9rKi3ygsM7CXHwCghgsqX6TOr55HE90DbEsoq3b/jjsD
/i8aIZ6urUgrpAkQslcakXdJLKgSdwjRUgVZgvYZb7kAx1iPq0t/AhB3NJw3zW4AAKJohGg3
xj5K4V8PJEZrSIpoRYlF43Kqlfu2p5ghWT89SP4YAlWPeTqf0+dTYUYz3b144k2ZFOdRuXIR
xunoYNAUr9oMrxBXbJ/eY+0UQX3pBACYzKizyY4JJgd0zFJmNkcdK9nzcm+btYFnYQo33w5G
SE686UNr+9yiXt9tmPRvNEbj3u+xoAX8B/5k3aZ5NbUhV64/VcKlUdRIxNlFCG7I9KgxeHWA
Ywi7yqOGXM3T/v6o7GLdQEB0ChFqS7kUlqmwLV+C3QhlrFe/Cuk26i+Q6rQiRmVkb3JhIFBy
b2plY3QgPGZlZG9yYUByZWRoYXQuY29tPohbBBMRAgAbBQI/nZ07BgsJCAcDAgMVAgMDFgIB
Ah4BAheAAAoJELRCadBPKm/S2PAAnRTlhorITphab+oxAHtbxZF9BVyDAJ9WOVaZUG53IWWI
AXOGv3j/cmr3lohGBBMRAgAGBQI/nZ22AAoJECGRgM3bQqYOR5QAoIp1G+omVktq/snxpmz5
UeHjlSYjAKCRr/ea/L7S7ZTxB18cf1TYfad1x4hGBBARAgAGBQI/ntjgAAoJECnVuiSN9W0F
USUAoJnrone4J0o1HMkRz+6g9KVuO2FyAJ0XyebOzVmI9U5OyOfnNmYV0wnQcrkBDQQ/nZ08
EAQAugOfLWJbKwMA9vg2mJU594TZU0HRJkx/fqYhx0YxWWRpzplrEyvcDXuYcWi1Hwh0tD86
T4fR5GV6joWiWClzD+Hwhhb6gcSdeSGlGLlZAvWYtFSHWiv+3LaI9w8Vtczl99Bh2WiMDNDD
Gw0RQg6ZaftldLSe4j1pffpFGQ8SuisAAwUEAKVxqLT7fC5xQ6oclcZ+PhoDlePQ1BiTS7tu
GM07bFF4nNvY91LL7S31pooz3XbGSWP8jxzSv1Fw35YhSmWGOBOEXluqMbVQGJJ5m8fqJOjC
0imbfeWgr/T7zLrJeiljDxvX+6TyawyWQngF6v1Hq6FRV0O0bOp9Npt5zqCbDGs/iEYEGBEC
AAYFAj+dnTwACgkQtEJp0E8qb9L//gCcDVYnDegNCOxDn1sedDwxw+0h8OcAn1CZHof15Qqx
nTwEnvwF2QeOI5dn
=mJAx
-----END PGP PUBLIC KEY BLOCK-----



gpg-pubkey.None                          db42a60e-37ea5438      installed
Matched from:
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: rpm-4.4.1 (beecrypt-3.0.0)

mQGiBDfqVDgRBADBKr3Bl6PO8BQ0H8sJoD6p9U7Yyl7pjtZqioviPwXP+DCWd4u8HQzcxAZ5
7m8ssA1LK1Fx93coJhDzM130+p5BG9mYSWShLabR3N1KXdXQYYcowTOMGxdwYRGr1Spw8Qyd
LhjVfU1VSl4xt6bupPbWJbyjkg5Z3P7BlUOUJmrx3wCgobNVEDGaWYJcch5z5B1of/41G8kE
AKii6q7Gu/vhXXnLS6m15oNnPVybyngiw/23dKjSZVG7rKANEK2mxg1VB+vc/uUc4k49UxJJ
fCZg1gu1sPFV3GSa+Y/7jsiLktQvCiLPlncQt1dV+ENmHR5BdIDPWDzKBVbgWnSDnqQ6KrZ7
T6AlZ74VMpjGxxkWU6vV2xsWXCLPA/9P/vtImA8CZN3jxGgtK5GGtDNJ/cMhhuv5tnfwFg4b
/VGo2Jr8mhLUqoIbE6zeGAmZbUpdckDco8D5fiFmqTf5+++pCEpJLJkkzel/32N2w4qzPrcR
MCiBURESPjCLd4Y5rPoU8E4kOHc/4BuHN903tiCsCPloCrWsQZ7UdxfQ5LQiUmVkIEhhdCwg
SW5jIDxzZWN1cml0eUByZWRoYXQuY29tPohVBBMRAgAVBQI36lQ4AwsKAwMVAwIDFgIBAheA
AAoJECGRgM3bQqYOsBQAnRVtg7B25Hm11PHcpa8FpeddKiq2AJ9aO8sBXmLDmPOEFI75mpTr
KYHF6rkCDQQ36lRyEAgAokgI2xJ+3bZsk8jRA8ORIX8DH05UlMH27qFYzLbT6npXwXYIOtVn
0K2/iMDj+oEB1Aa2au4OnddYaLWp06v3d+XyS0t+5ab2ZfIQzdh7wCwxqRkzR+/H5TLYbMG+
hvtTdylfqIX0WEfoOXMtWEGSVwyUsnM3Jy3LOi48rQQSCKtCAUdV20FoIGWhwnb/gHU1BnmE
S6UdQujFBE6EANqPhp0coYoIhHJ2oIO8ujQItvvNaU88j/s/izQv5e7MXOgVSjKe/WX3s2Jt
B/tW7utpy12wh1J+JsFdbLV/t8CozUTpJgx5mVA3RKlxjTA+On+1IEUWioB+iVfT7Ov/0kcA
zwADBQf9E4SKCWRand8K0XloMYgmipxMhJNnWDMLkokvbMNTUoNpSfRoQJ9EheXDxwMpTPwK
ti/PYrrL2J11P2ed0x7zm8v3gLrY0cue1iSba+8glY+p31ZPOr5ogaJw7ZARgoS8BwjyRymX
Qp+8Dete0TELKOL2/itDOPGHW07SsVWOR6cmX4VlRRcWB5KejaNvdrE54XFtOd04NMgWI63u
qZc4zkRa+kwEZtmbz3tHSdRCCE+Y7YVP6IUf/w6YPQFQriWYFiA6fD10eB+BlIUqIw80Vgjs
BKmCwvKkn4jg8kibXgj4/TzQSx77uYokw1EqQ2wkOZoaEtcubsNMquuLCMWijYhGBBgRAgAG
BQI36lRyAAoJECGRgM3bQqYOhyYAnj7hVDY/FJAGqmtZpwVp9IlitW5tAJ4xQApr/jNFZCTk
snI+4O1765F7tA==
=3AHZ
-----END PGP PUBLIC KEY BLOCK-----



gpg-pubkey.None                          1ac70ce6-41bebeef      installed
Matched from:
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: rpm-4.4.1 (beecrypt-3.0.0)

mQGiBEG+vu8RBACyH3cUSp+DXbyIvZ075bGDhjhRCf8m44UW2cCQdO/45CJBkRnCAA6SHthC
rXCVKIuuo1jSwy8kMXt1P/7IpF6Tc8ZMzcHKTyNetuuD/A7oavgnrJNbQVTScqbD6VrvjUAP
pDz5TMPqMMFYwylp+ySKMQpoPOYoqdNE3XwnA5vOywCg44+SKDWIV0j5xCeIAoa47VmgF2cE
AK/FIZRkbb7+i2Fob1mxKsnuLN/xx67aBpU2w7HOscVnkke08lRestDVk/6xb+lrq+gVLdNB
fAANBrOcwRv2heu+Zu3PZGuC166/JWFMkx5a9TkI0zQAw72LqKeX4VDBRz5fUoIs/C+3aGc5
Mh+h8fZYjJGf0kr/90rnd/0eWqsBA/9ONArdHN44aICt7xku/t98p9Da04A7kRYTHlLrBk5i
0U4JJXKei7ZAzNi4Or//8ATepQdsBMCJVx1Ss/vJKxupLG9Mw43nbNuA5SmOSPnAoyglYadK
yaUXBbVjmkqf9ZkjOMfD5u9PEWMWMq3f8uf05qxsrBDeiyc7Fk0jBYTvnrQ4RmVkb3JhIFBy
ZSBFeHRyYXMgUmVsZWFzZSA8cHJlLWV4dHJhc0BmZWRvcmFwcm9qZWN0Lm9yZz6IXgQTEQIA
HgUCQb6+7wIbAwYLCQgHAwIDFQIDAxYCAQIeAQIXgAAKCRCC7ZUEGscM5uAMAKC+XaPSCYIp
dcmJYEe9rNxYMz/hLwCeOyBYUYA2L0WnbfXuNafRqwta/s2IRgQSEQIABgUCQgD+/AAKCRC0
QmnQTypv0lVYAJoCLolPSuAj873GbV2+m3Bj6sS/UACeNcDmIWeruRld83uSQcx4xJyEOUa0
KUZlZG9yYSBQcm9qZWN0IDxmZWRvcmEtZXh0cmFzQHJlZGhhdC5jb20+iF4EExECAB4FAkIA
eFQCGwMGCwkIBwMCAxUCAwMWAgECHgECF4AACgkQgu2VBBrHDOYu8wCffLm57mvcYApV7eqv
HXr29gNAbLwAoJVqJWvgBIvg8/4MiqwKAQ1MDkIUiEYEEhECAAYFAkIA/wQACgkQtEJp0E8q
b9LQJACfc0LteS513+5O6erQO7RBUxC/NI4AniDHK+Ogf5l5Gs2ciwD+WApsZ4mPtDBGZWRv
cmEgUHJvamVjdCA8ZmVkb3JhLWV4dHJhc0BmZWRvcmFwcm9qZWN0Lm9yZz6IXgQTEQIAHgUC
QgB4iQIbAwYLCQgHAwIDFQIDAxYCAQIeAQIXgAAKCRCC7ZUEGscM5gZ7AJ9n8CYN6nvMqxCb
QQZwvs7e/J4//QCeM3nDwC5EfEbEtOHPIYAqTf3IQZaIRgQSEQIABgUCQgD/BAAKCRC0QmnQ
Typv0qKuAJ0cnqk9BbbblRSBbn72bK/BAquzywCeM7S0C6rfrYlfOjQHQdVB5GitT9u5AQ0E
Qb6+8RAEAJmsZ5apOFz0Fj6RwX0D+nOUAtdzd3zpTNzu4j8+L750ePutjuwizEmCxKycchuG
+gGasLmdxY+xk5AUB7gLt4mseKsWyHvQt+H4wG8jjOjHWXlaJkZaYQUxpVPd6/11hkoqpodJ
9ckfoIJnpUJWDcd3HTW7jdq+ZtBXjQlwvh3HAAMHA/9g50+hqjn23d91SaFTkvaAySZYHEF/
xm5sOV1XZ37XNFdl7JRl6BN7y59PE9Nk6qP4yHqH1G2YNDL3BmejChMF5GmEqluNdnvfFvwk
yqPvE7qCv8BhktPqsnrpFmtfeDFI4vztD08oab9LdkDvQwLHBZpc+wCb4VJzOkaZ7e7VP4hJ
BBgRAgAJBQJBvr7xAhsMAAoJEILtlQQaxwzmxdYAn3X4X/ENC3V4yPDR7X6oVeIVr5fvAJ4n
5vY10NpvYKV5arzKd8DSW2m5Bi==
=N/fy
-----END PGP PUBLIC KEY BLOCK-----



qt.i386                                  1:3.3.4-14             installed
Matched from:
qt
The shared library for the Qt GUI toolkit.
Qt is a GUI software toolkit which simplifies the task of writing and
maintaining GUI (Graphical User Interface) applications
for the X Window System.

Qt is written in C++ and is fully object-oriented.

This package contains the shared library needed to run qt
applications, as well as the README files for qt.




At this point the user runs screaming from the room.

So the reasons are:
 i) it confuses users
 ii) it's not useful to match partial gpg keys
 ii) we're covering up lack of a gui package manager as it is, why make it harder?
Comment 18 Seth Vidal 2005-06-21 11:22:14 EDT
I think what the user in the above case is looking for is yum list, not yum search.

yum list just matches on package name.

yum list qt\*

you don't want yum search at all for that.

Comment 19 Need Real Name 2005-06-21 11:24:50 EDT
Hm. This is interesting because I don't remember seeing "yum list" mentioned for
searches on the lists. "yum search" seems to be the common suggestion.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.